Bug 1328369 - Luc doesn't reuse already downloaded image and stuck
Luc doesn't reuse already downloaded image and stuck
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: 1310542 F24BetaBlocker F24BetaFreezeException
  Show dependency treegraph
 
Reported: 2016-04-19 04:31 EDT by Petr Schindler
Modified: 2016-09-19 22:47 EDT (History)
9 users (show)

See Also:
Fixed In Version: liveusb-creator-3.93.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 12:35:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2016-04-19 04:31:39 EDT
Description of problem:
See steps to reproduce.

Version-Release number of selected component (if applicable):
liveusb-creator-3.92.1-1.fc24.noarch

How reproducible:
I tried with Workstation and Server versions

Steps to Reproduce:
1. Use luc to put some variant (for example Workstation) on flash drive and close it after it is done.
2. Run luc again. Insert flash drive. Choose the same variant for downloading.

Actual results:
Luc doesn't download it nor it reuse cashed image. It just writes Starting and nothing happens.

Expected results:
Cashed image is reused.

Additional info:
Comment 1 Kamil Páral 2016-04-19 07:53:17 EDT
Same experience with liveusb-creator-3.92.1-1.fc23.noarch. No info in the terminal, even when running with --verbose.
Comment 2 Martin Bříza 2016-04-19 07:55:39 EDT
This actually usually works. If you're in the Brno office and try to download a 32b image, there goes your problem. There are none on the internal mirror for some reason.
There are multiple issues with urlgrabber though, such as high CPU usage and little to none error reporting which is why I'll have to port away it before the final release...
Comment 3 satellitgo 2016-04-19 08:01:25 EDT
Can you use custom os and choose the downloaded .iso in / ?
Comment 4 satellitgo 2016-04-19 08:18:33 EDT
If this is supposed to be the primary way to downlad and install f24; this needs to be fixed.
1-) should D/L to /Home/(user)/Downloads.
 LUC should remember this location while logged in
2-) allow a selection screen to appear to re choose the .iso to write to USB 
 before writing it.
Comment 5 Kamil Páral 2016-04-20 05:48:08 EDT
No, this is not about 32bit. I can download Workstation 64bit image once. But once I download it (and either write it or cancel the dialog), I can no longer "download" and write it again. It says "starting" and never continues.

If I remove ~/Fedora-Live-Workstation-x86_64-23-10.iso, FMR starts working again.
Comment 6 Kamil Páral 2016-04-20 06:08:58 EDT
Proposing as a Beta blocker, it seems to violate:
"Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."
https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria#Release-blocking_images_must_boot

A tool which is able to write the image only once and then stops working can't be considered really functional. However, a workaround is to select the iso image manually (which is further complicated by bug 1328457, and you also need to know where to look for it), or to remove the image and download it again (stupid), so there are some ways to go around this.
Comment 7 Stephen Gallagher 2016-04-20 13:58:20 EDT
(In reply to Kamil Páral from comment #6)
> Proposing as a Beta blocker, it seems to violate:
> "Release-blocking live and dedicated installer images must boot when written
> to optical media of an appropriate size (if applicable) and when written to
> a USB stick with any of the officially supported methods."
> https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria#Release-
> blocking_images_must_boot
> 
> A tool which is able to write the image only once and then stops working
> can't be considered really functional. However, a workaround is to select
> the iso image manually (which is further complicated by bug 1328457, and you
> also need to know where to look for it), or to remove the image and download
> it again (stupid), so there are some ways to go around this.

While I agree that this is a very serious bug, I don't think it violates that criterion at all. When the tool *works*, the image is bootable. I'm willing to listen to arguments that this violates the *spirit* of that criterion rather than the letter of it, though.
Comment 8 Kamil Páral 2016-04-21 04:15:07 EDT
Well, writing a succinct and clear criterion often goes against defining everything that can go wrong. But the "Difference from Alpha" I believe clearly indicates what is the intended meaning:
"This criterion differs from the similar Alpha criterion only in that it requires all supported methods of writing a Fedora USB stick to work, not just any single one."

I.e. not just "when the tools work, the images have to boot", but also "the tools have to work".
Comment 9 Fedora Update System 2016-04-21 12:13:26 EDT
liveusb-creator-3.93.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 10 Fedora Update System 2016-04-21 12:14:13 EDT
liveusb-creator-3.93.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 11 Fedora Update System 2016-04-21 18:00:44 EDT
liveusb-creator-3.93.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 12 Kamil Páral 2016-04-22 04:18:25 EDT
This is fixed with liveusb-creator-3.93.1-1.fc24.
Comment 13 Kamil Páral 2016-04-22 04:34:26 EDT
In case this is not granted a blocker status, we need at least an FE, this and many other bugs are fixed and waiting to be pushed (see deps of bug 1310542).
Comment 14 Adam Williamson 2016-04-22 12:44:18 EDT
I guess +1 FE, though it's more important to fix for f22 and f23 than f24.
Comment 15 Fedora Update System 2016-04-22 13:07:26 EDT
liveusb-creator-3.93.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 16 satellitgo 2016-04-22 13:13:56 EDT
liveusb-creator-3.93.1-1.fc23
liveusb-creator-3.93.1-1.fc24 	

This is fixed for me in f24 and f23 LUC.
If the .iso is not in default download directory Download starts.
If the .iso is present on hard disk:"Write to Disk" appears.
I have not tested for f22 but it should work the same way.
+1 FE
Comment 17 Fedora Update System 2016-04-23 21:25:45 EDT
liveusb-creator-3.93.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 18 Petr Schindler 2016-04-25 13:57:14 EDT
Discussed at 2016-04-25 blocker review meeting: [1]. 

This bug was accepted as Freeze Exception: this is clearly bad enough to merit a freeze exception. We are undecided on blocker status for now, will re-evaluate at Go/No-Go if it is not pushed stable for all releases by then

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2016-02-29/f24-blocker-review.2016-04-25-17.02.html
Comment 19 Fedora Update System 2016-04-26 04:14:12 EDT
liveusb-creator-3.93.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 20 Fedora Update System 2016-04-26 12:24:08 EDT
liveusb-creator-3.93.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff4136b90c
Comment 21 Fedora Update System 2016-04-26 12:33:44 EDT
liveusb-creator-3.93.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.