Bug 132865 - (radeon) monitor resolution/frequency is locked
(radeon) monitor resolution/frequency is locked
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
: 138104 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-18 05:31 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 14:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.85 KB, text/plain)
2004-09-18 05:32 EDT, Dams
no flags Details
Xorg.0.log (39.57 KB, text/plain)
2004-09-18 05:34 EDT, Dams
no flags Details
errors after running moz-mail (50.18 KB, text/plain)
2004-09-19 01:41 EDT, Jim Cornette
no flags Details

  None (edit)
Description Dams 2004-09-18 05:31:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Galeon/1.3.17

Description of problem:
My monitor seems to be locked in some bad resolution/frequency and it
seems i cant change it. The monitor resolution is way bigger than the
1600x1200 resolution i used to have. 

What i see on the screen is a normal-sized root window (with desktop
inside) located in the left-top corner of the screen and some big
black part in the bottom and right parts of the screen. 
I actually see something like that:
http://livna.org/~anvil/the-xorg-x11-0.6.8-effect.png

If i press ctrl alt +/-, the root window size changes but the monitor
stay in the say resolution/frequency (and, btw, this is killing my
eyes..).

My video card is a old radeon 7200 :

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD
[Radeon 7200] (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc Radeon 7000/Radeon
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping+ SERR- FastB2B-        Status: Cap+ 66Mhz+ UDF-
FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min), Cache Line Size 08
        Interrupt: pin A routed to IRQ 201
        Region 0: Memory at f4000000 (32-bit, prefetchable) [size=64M]
        Region 1: I/O ports at d800 [size=256]
        Region 2: Memory at f1800000 (32-bit, non-prefetchable)
[size=512K]
        Expansion ROM at f3fe0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=48 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW- AGP3- Rate=x1,x2,x4
                Command: RQ=16 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit-
FW- Rate=x1
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

The monitor is a mitsubishi 230SB and is well recognized by
system-config-display. The configuration file didnt so much change
from fedora core 2, but even Fedora Core 2 xorg.conf wont work. The
monitor Horiz/Vert frequencies in the config file didnt changed since
FC2. 

I'll attach X server output log and X configuration file.
I strongly doubt this has something to do with my desktop
configuration since it also happens with gdm/xdm and during the FC3T2
installation process.

Should i say i didnt have this problem with X11 R6.7 in FC2 ?

Version-Release number of selected component: xorg-x11(0:6.8.0-4).i386
How reproducible: Always
Comment 1 Dams 2004-09-18 05:32:50 EDT
Created attachment 103973 [details]
xorg.conf

xorg.conf generated by "system-config-display --reconfig" in FC3T2.
Comment 2 Dams 2004-09-18 05:34:36 EDT
Created attachment 103974 [details]
Xorg.0.log

The current X server output log.
Comment 3 Jim Cornette 2004-09-19 01:41:46 EDT
Created attachment 103994 [details]
errors after running moz-mail

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
comparative.
Comment 4 Dams 2004-09-22 13:13:52 EDT
I got the same problem with X11 6.8.1-3.
Comment 7 Dams 2004-09-29 03:41:27 EDT
ping ?
Comment 8 Mike A. Harris 2004-09-29 19:05:57 EDT
Thanks for the bug report.  This issue is being tracked as a
FC3Target bug, and will be reviewed and assessed during the
remaining Fedora Core development cycle.

Once we have reviewed the issue, we will provide a status
update.  You may also wish to report this issue to the X.Org
development team by filing a bug report in the X.Org bugzilla
located at http://bugs.freedesktop.org in the "xorg" component.

If you do file a bug report in the X.Org bugzilla, Red Hat
will also track the X.Org bug if you provide the upstream
bug report URL here, which may expediate finding a resolution
to this problem.

Thanks again for the report.

Comment 9 Dams 2004-10-03 05:13:56 EDT
Mike : it's done. http://freedesktop.org/bugzilla/show_bug.cgi?id=1514
Comment 10 Mike A. Harris 2004-10-04 05:45:05 EDT
Thanks Anvil, I've added myself to the CC upstream.
Comment 11 Scott Talbot 2004-10-06 12:42:28 EDT
I have seen this problem since first changes towards Xorg 6.8  X
worked fine in FC3 T1. reported to Xorg bugz #1175
Comment 12 Scott Talbot 2004-10-08 23:16:25 EDT
Just curious if anything has been heard from Xorg.  I doubt many old
radeon users will want to upgrade if they only have 1 video mode.
(Unless of course they buy a new video card.)
Comment 14 Mike A. Harris 2004-10-13 08:59:06 EDT
Status update:

This bug is a bug in the Radeon driver which no longer detects
the Radeon BIOS correctly on this older hardware, causing it to
fall back to failsafe defaults, only the failsafe defaults do not
work on old Radeon properly, and assume connector[0] is a DVI
panel, when on Radeon 7200, it is a CRT always.

A quick ugly hack would be to add code to handle Radeon 7200
differently by making it fallback to CRT always, and then use
the existing code for non 7200.

As an additional side note, comment #3 is completely unrelated
to this bug.

For anyone experiencing this problem, please CC yourself to the
upstream bug report where I've given a more detailed technical
analysis of the issue, and will do followups in the future.

Thanks.
Comment 15 Kevin E. Martin 2004-10-19 15:08:25 EDT
A patch is available here:
    https://freedesktop.org/bugzilla/attachment.cgi?id=1130
that fixes this problem on my test system.
Comment 16 Mike A. Harris 2004-10-20 15:47:11 EDT
Ok, we've integrated Hui Yu's patches into our latest build, and
it appears to work now on a variety of Radeon hardware.  The SEGVs
should no longer occur, however there are some problems with DDC
detection occuring in the driver.  The H/V ranges are read from
the monitor ok, but the dimensions aren't.  It acts as if EDID
is ignored.  I'm treating that as a separate non-critical bug
however, as the desktop starts up in 1600x1200 seemingly ok for
me now, although to get the correct DPI I have to specify
the monitor dimensions as returned by "ddcprobe".  Since ddcprobe
can probe the settings ok, I assume the DDC problem is a driver
bug.

This particular bug seems to be fixed now.  Please test the
xorg-x11-6.8.1-12 build and let us know as soon as possible if
it works for you now.

TIA
Comment 17 Dams 2004-10-21 13:02:53 EDT
Mike : it's pretty good for me. I have a 1600x1200 root window in a
physical 1600x1200 resolution. Ctrl-A-+/- works. The randr stuff works
too. I didnt notice anything bad in the current log
(http://livna.org/~anvil/Xorg.0.log). 
xorg-x11-6.8.1-12 is Good For Me(tm).

Thank you.
Comment 18 Scott Talbot 2004-10-22 13:22:21 EDT
just got this update and my radeon 7200 works great now!  Many
screenmodes is very nice.  Thanks to all!
xorg-x11-6.8.1-12 is Good For Me Too
Comment 19 Mike A. Harris 2004-10-22 14:23:25 EDT
Thanks for the feedback guys!  Glad this got fixed for FC3.
Comment 20 Fernando Gomes 2004-10-30 12:06:42 EDT
Hi!

I don know exactly if my report is related or not. So, here it is:

I have an old ATI AllInWonder128 (Rage 128 chipset).
I usually have 1600x1200 and everything is OK. But when I try to
logout or even shutdown from GUI, a bad frequency range is used and
monitor complaints about it. All ctrl-shifts and so doesnt work.

And even worse: the system itself freezes! I tryed to schedule a
shutdown for, say, 2 minutes and meanwhile I logout. The monitor
complaints as usual and shutdown never happens, even after hours.

If i need to change user or shutdown, I have to ctrl-shift-F1 and
force GUI restart (telinit 3 then telinit 5) or shutdown -h -y now.

Thank you all

Fernando Gomes
fernando DOT gomes AT bigfoot DOT com
Comment 21 Mike A. Harris 2004-11-29 08:24:43 EST
*** Bug 138104 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.