Bug 132896 - Many i386 gtk2 apps won't run on x86_64
Many i386 gtk2 apps won't run on x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 17:54 EDT by Bryan O'Sullivan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 01:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2004-09-18 17:54:48 EDT
Description of problem:

As an attempt to work around bug 132894, I installed the i386 version
of dia on my x86_64 box.  It crashes during startup, because it can't
load various gdkpixbuf components.  This appears to be due to
arch-specific pathnames in files in /etc/gtk-2.0.  The two offenders
on my machine are gdk-pixbuf.loaders and gtk.immodules, each of which
has hard-coded references to shared objects in /usr/lib64.

Version-Release number of selected component (if applicable):

gtk2-2.4.0-1

How reproducible:

100%

Steps to Reproduce:
1. Install 32-bit version of dia.
2. Run it.
3. Barf.
Comment 1 Matthias Clasen 2004-09-22 01:42:21 EDT
This is fixed in rawhide.
Comment 2 John Flanagan 2004-12-20 22:33:45 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-488.html

Note You need to log in before you can comment on or make changes to this bug.