Bug 132904 - XDMCP crashes x86_64 gdm
XDMCP crashes x86_64 gdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-18 23:56 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 22:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-09-18 23:56:13 EDT
Description of problem:
XDMCP connections to gdm x86_64 segfault.  I do not know how to attach
gdb to this because the instance of gdm-binary is launched with each
XDMCP connection.  Since it has no tty, it outputs to dmesg:

gdm-binary[18655]: segfault at 0000005596fc0570 rip 0000005596fc0570
rsp 0000007fbffff1e8 error 14

I have been unable to rebuild gdm due to Bug #132903, but it seems
judging by the changelog that the latest 2.6.0.5 upstream version does
not solve any problem like this.

Version-Release number of selected component (if applicable):
gdm-2.6.0.3-5
Comment 1 Sammy 2004-09-20 10:05:03 EDT
I am having the same problem on 386 architecture with "kdm". Using 
strace I found that if I have a x-terminal definition in /etc/X11/Xservers 
than kdm crashes. If I comment this line it does not. Is this similar or not. 
Plus, I am not sure where the problem is because KDE 3.2.3 kdm works 
fine! 
Comment 2 Sammy 2004-09-21 08:49:46 EDT
My problem was kdm related and has been fixed in the KDE_3_3_BRANCH. 
Comment 3 Warren Togami 2004-09-22 22:48:15 EDT
Seems fixed in September 22nd rawhide.

Note You need to log in before you can comment on or make changes to this bug.