Bug 1329051 - Unable to sync Atomic content from Red Hat CDN
Summary: Unable to sync Atomic content from Red Hat CDN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On: 1342168
Blocks: 1321771
TreeView+ depends on / blocked
 
Reported: 2016-04-21 03:17 UTC by Mike McCune
Modified: 2019-09-26 17:34 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, users had to synchronize the Atomic Kickstart Tree content manually through a custom repository. With this release, users can synchronize the Atomic Kickstart Tree content from within the Red Hat Content Delivery Network.
Clone Of:
Environment:
Last Closed: 2016-10-26 12:26:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
synced ostree contents from CDN via webUI (26.56 KB, image/png)
2016-05-13 09:47 UTC, Sachin Ghai
no flags Details
ostree sync is on going from last 38 minutes (34.88 KB, image/png)
2016-05-23 12:53 UTC, Sachin Ghai
no flags Details
Screenshot of endless sync in Sat6 snap 12.1 (150.26 KB, image/png)
2016-05-25 08:25 UTC, Nenad Peric
no flags Details
sync completed for ostree contents in 6 minutes (39.28 KB, image/png)
2016-10-13 10:23 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2108 normal SHIPPED_LIVE Satellite 6.2.3 Async Bug Release 2016-10-26 16:21:52 UTC

Description Mike McCune 2016-04-21 03:17:18 UTC
1) enable and synchronize the "Red Hat Enterprise Linux Atomic Host Trees" repository to Satellite 6.2

2) note that the sync never finishes, running 30-60 minutes without changing

manual syncs of similar sized repos take 3-10 minutes.

3) No recourse except to cancel task.


URL to feed is:

 https://cdn.redhat.com/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo

Comment 1 Partha Aji 2016-04-21 03:28:15 UTC
I tried the following on the same box -> after I copied the correct key, client cert and cacert  to /tmp

1) 
mkdir /root/el7 && ostree init --repo /root/el7

2) ostree remote add --set=tls-client-cert-path=/tmp/cert --set=tls-client-key-path=/tmp/key --set=tls-ca-path=/tmp/cacert --repo /root/el7 --set=tls-permissive=true --set=gpg-verify=false el7 https://cdn.redhat.com/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo rhel-atomic-host/7/x86_64/standard

3) 
sudo ostree pull el7 --repo /root/el7

1418 metadata, 13612 content objects fetched; 355536 KiB transferred in 331 seconds

Comment 3 Michael Hrivnak 2016-04-21 13:30:31 UTC
Do you have pulp's log output? Or the contents of the pulp task status?

Comment 4 Jeff Ortel 2016-04-21 14:12:03 UTC
Partha, please email me the certificates and key you used and I will reproduce/investigate.

Comment 5 Jeff Ortel 2016-04-22 01:52:32 UTC
(In reply to Partha Aji from comment #1)
> I tried the following on the same box -> after I copied the correct key,
> client cert and cacert  to /tmp
> 
> 1) 
> mkdir /root/el7 && ostree init --repo /root/el7
> 
> 2) ostree remote add --set=tls-client-cert-path=/tmp/cert
> --set=tls-client-key-path=/tmp/key --set=tls-ca-path=/tmp/cacert --repo
> /root/el7 --set=tls-permissive=true --set=gpg-verify=false el7
> https://cdn.redhat.com/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo
> rhel-atomic-host/7/x86_64/standard
> 
> 3) 
> sudo ostree pull el7 --repo /root/el7
> 
> 1418 metadata, 13612 content objects fetched; 355536 KiB transferred in 331
> seconds

Tried this ^ in Pulp and finished in ~2 minutes with no errors.

Comment 6 Sachin Ghai 2016-05-13 09:46:31 UTC
Yeah, I've synced the ostree repo from CDN with rhel6.2 GA snap10 and it was successfully synced without any issue and as per UI it took around 10-12 minutes.

Comment 7 Sachin Ghai 2016-05-13 09:47:10 UTC
Created attachment 1157057 [details]
synced ostree contents from CDN via webUI

Comment 8 Sachin Ghai 2016-05-23 12:52:07 UTC
This issue still persist. Its reproducible with snap12.1. I installed fresh setup on rhel7 w/ snap12.1 and sync is running from last 38 minutes.. I've synced rhel7 contents from CDN within that time frame.

Comment 9 Sachin Ghai 2016-05-23 12:53:01 UTC
Created attachment 1160611 [details]
ostree sync is on going from last 38 minutes

Comment 10 Sachin Ghai 2016-05-23 12:56:23 UTC
Another observation is: 

I was able to sync ostree contents from CDN in snap11. Later, I upgraded the satellite from snap11 -> sanp12.1 and re-sync the same repo and it failed with below error. I've filed separate bz 1338632 for this.

2016-05-23 03:29:08 [foreman-tasks/action] [E] OST0005: Fetch summary failed. Reason: GLib.Error('Server returned status 403: Forbidden', 'g-io-error-quark', 0) (Katello::Errors::PulpError)

Comment 11 Nenad Peric 2016-05-25 08:25:15 UTC
Created attachment 1161345 [details]
Screenshot of endless sync in Sat6 snap 12.1

Both in snap 12 and 12.1 the OSTree is syncing forever. 
It is stuck in sync for 18+ hours.

Will attach a screenshot.


Satellite rpm: 
satellite-6.2.0-12.1.el7sat.noarch

Comment 23 Partha Aji 2016-07-13 15:48:21 UTC
This should now work with updates from https://bugzilla.redhat.com/show_bug.cgi?id=1330753

Comment 24 Sachin Ghai 2016-10-13 10:20:20 UTC
Verified with sat6.2.3.

I synced Red Hat Atomic Hosts ostree contents from CDN and sync completed in 6 minutes. Please see the attached screenshot for verification.

Comment 25 Sachin Ghai 2016-10-13 10:23:40 UTC
Created attachment 1210000 [details]
sync completed for ostree contents in 6 minutes

Comment 27 errata-xmlrpc 2016-10-26 12:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108

Comment 28 Andrew Dahms 2017-10-05 00:38:12 UTC
Updated 'Doc Type'.


Note You need to log in before you can comment on or make changes to this bug.