Bug 132912 - No additional IP addresses at ethX without aliased devices
No additional IP addresses at ethX without aliased devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://www.redhat.com/archives/fedora...
bzcl34nup
:
: 113455 (view as bug list)
Depends On:
Blocks: FC5Target FC6Target
  Show dependency treegraph
 
Reported: 2004-09-19 10:21 EDT by Robert Scheck
Modified: 2014-03-16 22:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: initscripts-9.23-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-02 14:32:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
initscripts-8.05-rsc-linux.patch (2.58 KB, patch)
2005-03-23 07:07 EST, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-09-19 10:21:32 EDT
Description of problem:
Currently, I'm not able to set up additional IPv4 addresses at ethX 
devices using the /etc/sysconfig/network-scripts/ifcfg-ethX stuff 
(without using aliased devices) like it already is possible at IPv6.

My problem was also at the fedora-devel-list, but still ignored.

Version-Release number of selected component (if applicable):
initscripts-7.80-1

Actual results:
I'm trying to develop some patch/working thing/hack which gives me 
personally the missing functionality back. I also try to make my 
solution for this usable with the (redhat|system)-config-* things.

Expected results:
Additional IP addresses at ethX devices without the use of aliased 
devices but using the Red Hat initscripts configuration files.

Additional info:
My problem also is the same at RHEL3 - if my problem is solved for 
Fedora Core Development, I also would be very happy to see this 
improvment change merged to RHEL3's initscripts we use at work.
Comment 1 Matthew S. Hallacy 2004-12-21 09:34:07 EST
ifconfig man page:

       add addr/prefixlen
              Add an IPv6 address to an interface.

       del addr/prefixlen
              Remove an IPv6 address from an interface.


These are IPv6 only commands. Adding additional IPv4 addresses is not
currently possible without using aliased interfaces (eth0:x).

This is an upstream kernel feature enhancement request.
Comment 2 Robert Scheck 2004-12-21 10:11:52 EST
NO, it's definitely NOT an upstream kernel feature request - it's 
already possible and now ;-)

The old ifconfig is already obsoleted and shouldn't be used any longer.
The current tool for IP configuration is /sbin/ip out of the iproute2 
package. And iproute2 supports more than one IPv4 address per interface 
without using aliased interfaces.

Maybe you also should have a look to bug #132925 and #134816.
Comment 3 Matthew S. Hallacy 2004-12-21 11:26:58 EST
You are correct the ip command will add secondary addresses to an
interface. Unfortunately this does not display in ifconfig which _is_
used everywhere else. 

This should be filed against net-tools to update ifconfig, make it
announce that it's deprecated, or remove it entirely. Although I don't
see it going away anytime soon, and addresses hidden from ifconfig
will cause confusion.
Comment 4 Robert Scheck 2005-03-23 07:07:13 EST
Created attachment 112252 [details]
initscripts-8.05-rsc-linux.patch

A worse hack, but still working for me for months now - and the syntax format 
should also be no problem for system-config-network...

And Matthew, you always should prefer iproute2 rather ifconfig, the confusion
by the users will hide after some time. It's always the same with new things
;-)
Comment 5 Bill Nottingham 2005-09-30 17:56:58 EDT
*** Bug 113455 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Roesen 2005-12-25 17:47:32 EST
Any hope for FC5?
Comment 7 Robert Scheck 2005-12-25 17:53:19 EST
I guess not, since my patch is more a hack as a patch and nobody of the
Red Hat/Fedora folks is able and/or willing to provide a clean solution.
Same is at bug #132925, but it looks like that it has a chance for FC10 ;-)
Comment 8 Denis Ovsienko 2005-12-26 02:45:26 EST
We are close to releasing /etc/net 0.8.0, which will be tried to be packed for
Fedora Core/Extras. Multiple addresses just work. I hope it helps.
Comment 9 Robert Scheck 2005-12-26 06:59:35 EST
Denis, that sounds great, but will it really receive Fedora Core or will it
only packaged for Fedora Extras...Bill? So, if it will be just a package in 
Fedora Extras instead of replacing the current stuff in Core, it isn't the 
solution I (and maybe lots of other people) really would like to see.
Comment 10 Denis Ovsienko 2005-12-26 07:33:08 EST
I will let know when there is anything to show. There is nothing in Extras ATM
and I'm not making hope about Core.
Comment 11 Robert Scheck 2006-05-31 17:06:19 EDT
Ping...any chance for FC6?
Comment 12 Denis Ovsienko 2006-06-06 12:39:18 EDT
I am trying to continue my work.
Comment 13 Denis Ovsienko 2006-06-14 17:48:23 EDT
Robert,
as long as FC6 is expected to be freezed today, there seems to be no chance, but
here is what I managed to do ATM:
#195353
#195365
I hope it helps.
Comment 14 Robert Scheck 2006-06-14 18:34:29 EDT
Denis, it is only freeze of devel 1 of FC6 (as per http://fedoraproject.org/
wiki/Core/Schedule). Package looks nice in general, but you should review it 
using rpmlint (also in Extras). Redefining mandirs inside of the spec file is 
not what is likely seen, IIRC. But discussion should moved to the corresponding 
bug reports now...
Comment 15 Robert Scheck 2007-04-20 18:13:07 EDT
Well, Fedora 10 is not such far away now...Bill! :)
Comment 16 Bug Zapper 2008-04-03 11:39:32 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 17 Robert Scheck 2008-04-03 11:47:58 EDT
Hum? Since when is Rawhide no longer maintained? The problem still exists in 
Rawhide.
Comment 18 Bug Zapper 2008-05-13 21:57:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Bug Zapper 2009-06-09 05:06:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Bug Zapper 2010-04-27 07:35:33 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Robert Scheck 2010-04-27 07:43:52 EDT
The problem still exists in Rawhide.
Comment 22 Bug Zapper 2010-07-30 06:25:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Bill Nottingham 2010-11-30 21:54:46 EST
In the waaaaay waaaay late and hopefully better than never department.

http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=ff5befb95b133cc1da3f32ffcd9f3cef779244b6

Note You need to log in before you can comment on or make changes to this bug.