Bug 132922 - Excuted themes:/// in nautilus, nautilus crashes.
Excuted themes:/// in nautilus, nautilus crashes.
Status: CLOSED DUPLICATE of bug 130967
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-19 13:39 EDT by sangu
Modified: 2013-04-02 00:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2004-09-19 13:39:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.4.0

Description of problem:
Excuted themes:/// in nautilus, nautilus crashes.

Backtrace was generated from '/usr/bin/nautilus'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -169941952 (LWP 3913)]
[New Thread -186242128 (LWP 3923)]
[Thread debugging using libthread_db enabled]
[New Thread -169941952 (LWP 3913)]
[New Thread -186242128 (LWP 3923)]
[Thread debugging using libthread_db enabled]
[New Thread -169941952 (LWP 3913)]
[New Thread -186242128 (LWP 3923)]
[New Thread -185975888 (LWP 3922)]
[New Thread -185709648 (LWP 3921)]
[New Thread -185443408 (LWP 3920)]
[New Thread -185177168 (LWP 3919)]
[New Thread -184910928 (LWP 3918)]
[New Thread -184644688 (LWP 3917)]
[New Thread -184378448 (LWP 3916)]
[New Thread -184112208 (LWP 3915)]
[New Thread -173610064 (LWP 3914)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...0xf6fe9782
in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xf6ba007b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0xf6d6ea30 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0xf656df19 in g_str_hash () from /usr/lib/libglib-2.0.so.0
#5  0xf654c29f in g_hash_table_lookup () from /usr/lib/libglib-2.0.so.0
#6  0xf1aa8e9c in gnome_theme_info_new () from
/usr/lib/gnome-vfs-2.0/modules/libtheme-method.so
#7  0xf6681b40 in _gnome_vfs_monitor_do_cancel () from
/usr/lib/libgnomevfs-2.so.0
#8  0xf6559848 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#9  0xf65564fb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#10 0xf6557f82 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#11 0xf655822f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#12 0xf69601de in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x08077916 in main ()

Thread 11 (Thread -173610064 (LWP 3914)):
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0xf63d2a34 in poll () from /lib/tls/libc.so.6
No symbol table info available.
#2  0xf6557f13 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0xf655822f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0xf6616dd0 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0xf65ad1a4 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0xf5a6eaa8 in ?? ()
No symbol table info available.
#7  0xf65705c2 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2


Version-Release number of selected component (if applicable):
control-center-2.7.1-3

How reproducible:
Always

Steps to Reproduce:
1. ctrl + L in nautilus
2. themes:///
3.
    

Additional info:

nautilus-2.7.92-3, gnome-vfs2-2.7.92-3
Comment 1 Daniel Veillard 2004-09-21 10:19:21 EDT
Okay I have just rechecked that, on a fully up-to-date rawhide
setup (fc3-devel), and this doesn't crash.
My guess is that 
  #7  0xf6681b40 in _gnome_vfs_monitor_do_cancel () from
      /usr/lib/libgnomevfs-2.so.0
was the cause of the problem when using one of the earlier version
of gamin, this would potentially free() a wrong memory area when
cancelling a monitoring, i.e. similar to bug #130967 where the
crash shows up directly when FAMCancelMonitor () from
/usr/lib/libfam.so.0 is called.

  I think the fix relies on upgrading gamin to a version >= 0.0.9
and unless this can be reproduced in such an environment, I suspect
it's the same problem as #130967

Daniel

*** This bug has been marked as a duplicate of 130967 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.