Bug 132948 - r-c-p utility and cups service have been broken started in non-english locales
r-c-p utility and cups service have been broken started in non-english locales
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 06:17 EDT by Andy Shevchenko
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quick fix of described problem (1.71 KB, patch)
2004-09-20 06:33 EDT, Andy Shevchenko
no flags Details | Diff

  None (edit)
Description Andy Shevchenko 2004-09-20 06:17:52 EDT
Description of problem:
redhat-config-printer utility has broken call of alternatives tool.

[root@localhost root]# locale
LANG=ru_RU.CP1251
LC_CTYPE="ru_RU.CP1251"
LC_NUMERIC="ru_RU.CP1251"
LC_TIME="ru_RU.CP1251"
LC_COLLATE="ru_RU.CP1251"
LC_MONETARY="ru_RU.CP1251"
LC_MESSAGES="ru_RU.CP1251"
LC_PAPER="ru_RU.CP1251"
LC_NAME="ru_RU.CP1251"
LC_ADDRESS="ru_RU.CP1251"
LC_TELEPHONE="ru_RU.CP1251"
LC_MEASUREMENT="ru_RU.CP1251"
LC_IDENTIFICATION="ru_RU.CP1251"
LC_ALL=

[root@localhost root]# redhat-config-printer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    debug1: channel 1: FORCE input drain
import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

Version-Release number of selected component (if applicable):
[root@localhost root]# rpm -q redhat-config-printer
redhat-config-printer-0.6.47.3.19-1

How reproducible:
Only try to start it.
  
Expected results:
Properly work.

Additional info:
I propose to write 'LC_MESSAGES=C /usr/sbin/alternatives ...' into 
/usr/share/printconf/util/cups_import.py as quick fix.
Comment 1 Andy Shevchenko 2004-09-20 06:33:23 EDT
Created attachment 104009 [details]
quick fix of described problem

The alternatives call are discovered at three files:
- printconf_conf.py
- queueTree.py
- cups_import.py
Comment 2 Milan Kerslager 2004-09-21 09:52:12 EDT

*** This bug has been marked as a duplicate of 131563 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.