Bug 132949 (IT_50150) - cups-lpd is very slow with many printqueues
Summary: cups-lpd is very slow with many printqueues
Status: CLOSED WONTFIX
Alias: IT_50150
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cups (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 154834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-20 10:36 UTC by Niels Happel
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:18:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Niels Happel 2004-09-20 10:36:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
While using cups-lpd with about 7500 printqueues printing a small
document takes very long time and its impossible to print more than 30
jobs per minute.
While printing directly to cups via ipp or http there�s no problem
handling thousands of printqueues with an acceptable performance.
I found out that cups-lpd is polling the whole printqueues via the lo
interface from the cupsd (with 7500 printqueues its about 14MB traffic
on the lo interface for each printjob) before selecting the right one
and send the job to it.
This behaviour is very bad and slows down systems with many
printqueues dramatically.


Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.12

How reproducible:
Always

Steps to Reproduce:
1.set up 7000 print queues
2.print a small document via lpd
3.see what happens on lo and how long it takes
    

Actual Results:  The cups-lpd acts very slow and catches nearly all
systemressources.

Expected Results:  It should send out small printjobs very quick.

Additional info:

Comment 1 Bastien Nocera 2004-10-04 15:24:01 UTC
Upstream bug:
http://www.cups.org/str.php?L804

Comment 5 Tim Waugh 2005-04-19 16:48:33 UTC
*** Bug 154834 has been marked as a duplicate of this bug. ***

Comment 6 RHEL Product and Program Management 2007-10-19 19:18:02 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.