Bug 1329501 - self-heal does fsyncs even after setting ensure-durability off
Summary: self-heal does fsyncs even after setting ensure-durability off
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1331342
TreeView+ depends on / blocked
 
Reported: 2016-04-22 06:26 UTC by Pranith Kumar K
Modified: 2016-06-16 14:04 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1331342 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:04:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-04-22 06:26:06 UTC
Description of problem:
It is observed that self-heal is doing fsync even after setting ensure-durability off option

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-04-22 06:26:42 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-04-22 06:31:50 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Vijay Bellur 2016-04-25 18:35:11 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Vijay Bellur 2016-04-26 02:30:27 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Vijay Bellur 2016-04-26 04:52:11 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Vijay Bellur 2016-04-26 04:54:15 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 7 Vijay Bellur 2016-04-27 11:26:30 UTC
REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#7) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 8 Vijay Bellur 2016-04-27 15:06:38 UTC
COMMIT: http://review.gluster.org/14048 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 302e218f68ef5edab6b369411d6f06cafea08ce1
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Apr 22 11:43:45 2016 +0530

    cluster/afr: Do not fsync when durability is off
    
    BUG: 1329501
    Change-Id: Id402c20f2fa19b22bc402295e03e7a0ea96b0c40
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14048
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 9 Niels de Vos 2016-06-16 14:04:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.