Bug 1331342 - self-heal does fsyncs even after setting ensure-durability off
Summary: self-heal does fsyncs even after setting ensure-durability off
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.7.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1329501
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-28 10:36 UTC by Pranith Kumar K
Modified: 2016-06-28 12:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1329501
Environment:
Last Closed: 2016-06-28 11:29:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-04-28 10:36:46 UTC
+++ This bug was initially created as a clone of Bug #1329501 +++

Description of problem:
It is observed that self-heal is doing fsync even after setting ensure-durability off option

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-04-22 02:26:42 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-22 02:31:50 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-25 14:35:11 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-25 22:30:27 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-26 00:52:11 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-26 00:54:15 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-27 07:26:30 EDT ---

REVIEW: http://review.gluster.org/14048 (cluster/afr: Do not fsync when durability is off) posted (#7) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-04-27 11:06:38 EDT ---

COMMIT: http://review.gluster.org/14048 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 302e218f68ef5edab6b369411d6f06cafea08ce1
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Apr 22 11:43:45 2016 +0530

    cluster/afr: Do not fsync when durability is off
    
    BUG: 1329501
    Change-Id: Id402c20f2fa19b22bc402295e03e7a0ea96b0c40
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14048
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 1 Vijay Bellur 2016-04-28 11:17:54 UTC
REVIEW: http://review.gluster.org/14104 (cluster/afr: Do not fsync when durability is off) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-04-29 17:49:40 UTC
COMMIT: http://review.gluster.org/14104 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4bba976e7a61d9961a133b2b61e56eb0871d3ba2
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Apr 22 11:43:45 2016 +0530

    cluster/afr: Do not fsync when durability is off
    
     >BUG: 1329501
     >Change-Id: Id402c20f2fa19b22bc402295e03e7a0ea96b0c40
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/14048
     >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
     >(cherry picked from commit 302e218f68ef5edab6b369411d6f06cafea08ce1)
    
    Change-Id: Ifbf693f8de6765fca90a9ef3c11c1912c2e9885f
    BUG: 1331342
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14104
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Kaushal 2016-06-28 12:15:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.