Bug 1329587 - please update kombu to 3.x series
Summary: please update kombu to 3.x series
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-kombu
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1448466
Blocks: 1191235
TreeView+ depends on / blocked
 
Reported: 2016-04-22 09:58 UTC by Jakub Filak
Modified: 2019-02-06 00:58 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-02-06 00:58:42 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1424126 None CLOSED python-amqpclt: FTBFS in rawhide 2019-01-29 12:07 UTC

Internal Trackers: 1424126

Description Jakub Filak 2016-04-22 09:58:58 UTC
Description of problem:
python-celery requires python-kombu >= 3.0.8 (bug #1191235).

It looks like no one has problem with updating kombu to 3.x series:
https://lists.fedoraproject.org/archives/list/epel-devel@lists.fedoraproject.org/message/XYD5JWWG3ITGTZY3VVME23L5FHX3B7QV/

Comment 2 Raphael Groner 2017-04-05 17:07:22 UTC
python-amqpclt seems to need Kombu 3 but does not work with Kombu 4. There's no build of python-amqpclt available for epel7 although a branch exists, right?

Comment 3 Brian J. Murrell 2017-04-06 17:27:16 UTC
We too would like to see this happen.

Is anything blocking it?

Comment 4 Matthias Runge 2017-05-03 08:52:09 UTC
version 4 is a major release bump, and needs a careful re-sync over all requiring packages, otherwise we'll break existing users.
There is a policy for this:
https://fedoraproject.org/wiki/EPEL_Updates_Policy#Stable_Releases

Comment 5 Brian J. Murrell 2017-05-03 13:14:57 UTC
(In reply to Matthias Runge from comment #4)
> version 4 is a major release bump, and needs a careful re-sync over all
> requiring packages, otherwise we'll break existing users.
> There is a policy for this:
> https://fedoraproject.org/wiki/EPEL_Updates_Policy#Stable_Releases

This ticket seems to be about kombu 3.x, not 4.x.  So if we can avoid being distracted about 4.x aside and make progress on a 3.x upgrade, that would be great.

Comment 6 Matthias Runge 2017-05-05 13:15:07 UTC
The naive approach failed due to 

https://kojipkgs.fedoraproject.org//work/tasks/713/19410713/root.log

Error: No Package found for python-pymongo

python-pymongo is available on x86_64, but not like in this case on ppc

Comment 7 Matthias Runge 2017-05-05 13:18:09 UTC
Forgot:
pkg_resources.VersionConflict: (amqp 1.4.5 (/usr/lib/python2.7/site-packages), Requirement.parse('amqp>=1.4.9,<2.0'))

amqp in epel7 is 1.4.5

Comment 8 Raphael Groner 2018-11-11 08:36:09 UTC
Re comment #2, FTR python-amqpclt got retired in Fedora and there's no package in EPEL, see bug #1424126.

Comment 9 Fedora Update System 2019-01-29 01:15:13 UTC
python-kombu-4.2.2-1.el7 python-vine-1.2.0-1.el7 pagure-5.2-2.el7 python-billiard-3.5.0.5-1.el7 python-amqp-2.4.0-1.el7 python-celery-4.2.1-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 10 Fedora Update System 2019-01-30 02:22:45 UTC
pagure-5.2-2.el7, python-amqp-2.4.0-1.el7, python-billiard-3.5.0.5-1.el7, python-celery-4.2.1-3.el7, python-kombu-4.2.2-1.el7, python-vine-1.2.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 11 Fedora Update System 2019-02-01 02:30:32 UTC
pagure-5.2-2.el7 python-amqp-2.4.0-1.el7 python-billiard-3.5.0.5-1.el7 python-celery-4.2.1-3.el7 python-kombu-4.2.2-1.el7 python-redis-2.10.6-1.el7 python-vine-1.2.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 12 Fedora Update System 2019-02-02 00:48:38 UTC
pagure-5.2-2.el7, python-amqp-2.4.0-1.el7, python-billiard-3.5.0.5-1.el7, python-celery-4.2.1-3.el7, python-kombu-4.2.2-1.el7, python-redis-2.10.6-1.el7, python-vine-1.2.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 13 Fedora Update System 2019-02-06 00:58:42 UTC
pagure-5.2-2.el7, python-amqp-2.4.0-1.el7, python-billiard-3.5.0.5-1.el7, python-celery-4.2.1-3.el7, python-kombu-4.2.2-1.el7, python-redis-2.10.6-1.el7, python-vine-1.2.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.