Bug 1191235 - Please add python-celery to EPEL7 build
Summary: Please add python-celery to EPEL7 build
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-celery
Version: epel7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Andrew Colin Kissa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1329587
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-10 19:23 UTC by Patrick Smears
Modified: 2019-02-06 00:58 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-02-06 00:58:49 UTC


Attachments (Terms of Use)

Description Patrick Smears 2015-02-10 19:23:27 UTC
Description of problem:


This package is currently not build for EPEL7; it would be really great if
it could be.

Comment 1 Ofer Hasson 2015-03-06 16:01:42 UTC
I agree, this will be really helpful

Comment 2 Richard Marko 2015-08-26 11:17:47 UTC
+1

Comment 3 Richard Marko 2015-08-26 13:08:54 UTC
I was able to build recent celery in copr:

https://copr.fedoraproject.org/coprs/rmarko/python-celery/

There are only two deps that need updating:

- python-billiard (I've requested epel7 branch, will be in epel7 soon)
- python-kombu (bit more complicated, has epel7 branch with older release)

While kombu builds fine we need to give heads-up to epel7 users/devs prior updating to make sure the update doesn't break anything.

Comment 4 Fedora Update System 2015-08-26 13:41:39 UTC
python-billiard-3.3.0.20-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7802

Comment 5 Fedora Update System 2015-08-26 22:49:16 UTC
python-billiard-3.3.0.20-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update python-billiard'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7802

Comment 6 Fedora Update System 2016-05-12 04:39:42 UTC
python-billiard-3.3.0.20-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Brian Bouterse 2016-12-01 20:07:16 UTC
Celery 4.0 is the current upstream version. Since EPEL7 prevents backwards incompatible changes and Celery X releases are backwards compatible, we should add Celery 4.0 instead of the 3.1 line. What do others think about this change?

Note, I'm about to upgrade Fedora Rawhide to use 4.0 also:  https://bugzilla.redhat.com/show_bug.cgi?id=1400270

Comment 8 Fedora Update System 2019-01-29 01:15:19 UTC
python-kombu-4.2.2-1.el7 python-vine-1.2.0-1.el7 pagure-5.2-2.el7 python-billiard-3.5.0.5-1.el7 python-amqp-2.4.0-1.el7 python-celery-4.2.1-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 9 Fedora Update System 2019-01-30 02:22:53 UTC
pagure-5.2-2.el7, python-amqp-2.4.0-1.el7, python-billiard-3.5.0.5-1.el7, python-celery-4.2.1-3.el7, python-kombu-4.2.2-1.el7, python-vine-1.2.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 10 Fedora Update System 2019-02-01 02:30:37 UTC
pagure-5.2-2.el7 python-amqp-2.4.0-1.el7 python-billiard-3.5.0.5-1.el7 python-celery-4.2.1-3.el7 python-kombu-4.2.2-1.el7 python-redis-2.10.6-1.el7 python-vine-1.2.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 11 Fedora Update System 2019-02-02 00:48:44 UTC
pagure-5.2-2.el7, python-amqp-2.4.0-1.el7, python-billiard-3.5.0.5-1.el7, python-celery-4.2.1-3.el7, python-kombu-4.2.2-1.el7, python-redis-2.10.6-1.el7, python-vine-1.2.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd9e038712

Comment 12 Fedora Update System 2019-02-06 00:58:49 UTC
pagure-5.2-2.el7, python-amqp-2.4.0-1.el7, python-billiard-3.5.0.5-1.el7, python-celery-4.2.1-3.el7, python-kombu-4.2.2-1.el7, python-redis-2.10.6-1.el7, python-vine-1.2.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.