Bug 132998 - amd-64 dvd iso image too large to fit on a dvd
amd-64 dvd iso image too large to fit on a dvd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
other Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
: 133452 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-20 15:34 EDT by Uttiya Chowdhury
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 05:34:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
shell script to remaster FC3test2 X86_64 DVD .iso (2.31 KB, text/plain)
2004-10-06 02:19 EDT, D. Hugh Redelmeier
no flags Details

  None (edit)
Description Uttiya Chowdhury 2004-09-20 15:34:04 EDT
Description of problem: 
AMD-64 dvd iso image of fedora core 3 test 2 (2.91) is 
4.6GB in size while a blank dvd disk will only hold 4.4GB. 
The i386 dvd iso image is rightly sized though. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
 
 
Expected results: 
 
 
Additional info:
Comment 1 Bill Nottingham 2004-09-24 14:30:59 EDT
*** Bug 133452 has been marked as a duplicate of this bug. ***
Comment 2 Uttiya Chowdhury 2004-09-24 19:00:47 EDT
Interestingly, I burnt the DVD image using overburn option (which 
basically simply ignores that the image is larger than the disk and 
writes as much as it can) and did a successful install using that. I 
guess for this install, the installation program simply didn't call 
for the packages that were not burnt on the disk... 
Comment 3 C.H. 2004-09-25 06:57:24 EDT
The problem with 'overburn' mode is that it'll basically
ignore the fact that there really isn't enough space, and proceed
anyway.  In this case serendipity may be on our side and the resultant
disc is installable, but one doesn't know what, if anything, actually
'gets lost' / corrupted without some extensive investigation.
For this reason (and general principle) I've commended placing MD5/SHA1
hashes on all discs as a standard process --
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133624

growisofs -overburn -Z /dev/sr1=../FC3-test2-x86_64-DVD.iso
About to execute 'builtin_dd if=../FC3-test2-x86_64-DVD.iso
of=/dev/sr1 obs=32k seek=0'
:-( /dev/sr1: not enough space available to accomodate this volume!
:-! ignoring...
:-( /dev/sr1: 2295104 blocks are free, 2387426 to be written
:-! ignoring...
...
4697325568/4700372992 (99.9%) @2.4x, remaining 0:00
:-[ LBA=230540h, SENSE KEY=5h/ASC=21h/ASCQ=00h ]
:-( write failed: Input/output error

So the image is exactly 
189,075,456 bytes too large, which is much larger than is
possible by any account I'm aware of to possibly overburn on
a standard DVD+/-R/RW without data loss.
Looking at a directory of the files on the disc sorted by size,
I'd vote for leaving out the OpenOffice / Koffice / KDE SRPMs
which are quite large... and by the time anyone wants to hack
on office applications they probably have a pretty well functioning
system which can be used to download the SRPMs / CVS for those.

To check the integrity of your disc -- 

mount FC3-test2-x86_64-DVD.iso /media/loop0 -t iso9660 -o
ro,loop=/dev/loop3,blocksize=2048

(cd /media/loop0 ; find . -type f -print0 | xargs -0 md5sum --binary )
> FC3-test2-x86_64-DVD.iso.loopback.files0.md5s

(cd /media/sr1 ; find . -type f -print0 | xargs -0 md5sum --binary ) >
FC3-test2-x86_64-DVD.iso.burned.files0.md5s

Then a diff --minimal of 
FC3-test2-x86_64-DVD.iso.loopback.files0.md5s
and 
FC3-test2-x86_64-DVD.iso.burned.files0.md5s
shows the following corrupted files -- fortunately none
of them seem needed for the basic install --

./SRPMS/vnc-4.0-6.src.rpm
./SRPMS/vorbis-tools-1.0.1-4.src.rpm
./SRPMS/vsftpd-2.0.1-2.src.rpm
./SRPMS/vte-0.11.11-2.src.rpm
./SRPMS/w3c-libwww-5.4.0-10.src.rpm
./SRPMS/w3m-0.5.1-4.src.rpm
./SRPMS/w3m-el-1.4.3-1.src.rpm
./SRPMS/webalizer-2.01_10-25.src.rpm
./SRPMS/wget-1.9.1-13.src.rpm
./SRPMS/which-2.16-4.src.rpm
./SRPMS/wireless-tools-27-0.pre25.1.src.rpm
./SRPMS/wl-2.10.1-3.src.rpm
./SRPMS/words-2-22.src.rpm
./SRPMS/wordtrans-1.1pre13-7.src.rpm
./SRPMS/wvdial-1.54.0-2.src.rpm
./SRPMS/x3270-3.3.2.p1-6.src.rpm
./SRPMS/xalan-j-2.4.1-16.src.rpm
./SRPMS/Xaw3d-1.5-23.src.rpm
./SRPMS/xboard-4.2.7-5.src.rpm
./SRPMS/xcdroast-0.98a15-5.src.rpm
./SRPMS/xchat-2.4.0-2.src.rpm
./SRPMS/xcin-2.5.3.pre3-24.src.rpm
./SRPMS/xdelta-1.1.3-14.src.rpm
./SRPMS/xemacs-21.4.15-7.src.rpm
./SRPMS/xemacs-sumo-20040818-1.src.rpm
./SRPMS/xerces-j-2.2.1-17.src.rpm
./SRPMS/xfce4-iconbox-4.0.6-2.src.rpm
./SRPMS/xfce4-panel-4.0.6-1.src.rpm
./SRPMS/xfce4-systray-4.0.6-1.src.rpm
./SRPMS/xfce-mcs-manager-4.0.6-2.src.rpm
./SRPMS/xfce-mcs-plugins-4.0.6-2.src.rpm
./SRPMS/xfce-utils-4.0.6-1.src.rpm
./SRPMS/xfdesktop-4.0.6-2.src.rpm
./SRPMS/xferstats-2.16-11.src.rpm
./SRPMS/xffm-4.0.6-1.src.rpm
./SRPMS/xffm-icons-4.0.6-2.src.rpm
./SRPMS/xfig-3.2.4-5.src.rpm
./SRPMS/xfprint-4.0.6-2.src.rpm
./SRPMS/xfsprogs-2.6.13-2.src.rpm
./SRPMS/xfwm4-4.0.6-1.src.rpm
./SRPMS/xfwm4-themes-4.0.6-1.src.rpm
./SRPMS/xhtml1-dtds-1.0-7.src.rpm
./SRPMS/xinetd-2.3.13-4.src.rpm
./SRPMS/xinitrc-4.0.4-1.src.rpm
./SRPMS/xloadimage-4.1-31.src.rpm
./SRPMS/xmlsec1-1.2.6-3.src.rpm
./SRPMS/xmltex-20020625-2.src.rpm
./SRPMS/xmlto-0.0.18-4.src.rpm
./SRPMS/xmms-1.2.10-6.src.rpm
./SRPMS/xorg-x11-6.8.0-4.src.rpm
./SRPMS/xosview-1.8.2-1.src.rpm
./SRPMS/xpdf-3.00-5.src.rpm
./SRPMS/xrestop-0.2-3.src.rpm
./SRPMS/xsane-0.92-13.src.rpm
./SRPMS/xscreensaver-4.18-3.src.rpm
./SRPMS/xsnow-1.42-15.src.rpm
./SRPMS/xsri-2.1.0-8.src.rpm
./SRPMS/xterm-192-1.src.rpm
./SRPMS/yelp-2.6.2-2.src.rpm
./SRPMS/ypbind-1.17.2-2.src.rpm
./SRPMS/ypserv-2.13-4.src.rpm
./SRPMS/yp-tools-2.8-7.src.rpm
./SRPMS/ytalk-3.1.1-16.src.rpm
./SRPMS/yum-2.1.3-1.src.rpm
./SRPMS/zip-2.3-24.src.rpm
./SRPMS/zisofs-tools-1.0.6-1.src.rpm
./SRPMS/zlib-1.2.1.2-1.src.rpm
./SRPMS/zsh-4.2.0-3.src.rpm

YMMV
Comment 4 D. Hugh Redelmeier 2004-10-06 02:19:27 EDT
Created attachment 104824 [details]
shell script to remaster FC3test2 X86_64 DVD .iso

I've created a script to take the .iso and remaster it without the OpenOffice
and koffice SRPMs.  The resulting .iso works for me.  I will attach the script.
 Be sure to review it before running it.  The initial definitions will need to
be adjusted for your environment.
Comment 5 Warren Togami 2004-10-09 18:30:24 EDT
FC3T3's x86_64 ISO is 2630025216 bytes.  Appears that SRPMS were
removed. I believe this issue is solved.
Comment 6 Jay Turner 2004-10-14 05:34:33 EDT
Closing this out, as the DVD image is indeed small enough now to fit.

Note You need to log in before you can comment on or make changes to this bug.