Bug 1330023 - The content of deep-scrub is overwritten by shallow-scrub
Summary: The content of deep-scrub is overwritten by shallow-scrub
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.3
Assignee: David Zafman
QA Contact: vidushi
Erin Donnelly
URL:
Whiteboard:
Depends On:
Blocks: 1322504 1383917 1412948 1437916
TreeView+ depends on / blocked
 
Reported: 2016-04-25 10:07 UTC by Tanay Ganguly
Modified: 2017-07-30 15:17 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-10.2.7-2.el7cp Ubuntu: ceph_10.2.7-3redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Results from deep scrubbing are no longer overwritten by shallow scrubbing Previously, when performing shallow scrubbing after deep scrubbing, results from deep scrubbing were overwritten by results from shallow scrubbing. As a consequence, the deep scrubbing results were lost. Now, unless the `nodeep_scrub` flag is set, no shallow scrubbing is performed regularly, so the information from deep scrubbing is regenerated.
Clone Of:
Environment:
Last Closed: 2017-06-19 13:25:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 18113 None None None 2017-04-06 23:15:15 UTC

Description Tanay Ganguly 2016-04-25 10:07:07 UTC
Description of problem:
The content of deep-scrub is overwritten by shallow-scrub

Version-Release number of selected component (if applicable):
10.1.1.1

How reproducible:
NA

Steps to Reproduce:
For a PG which have deep scrub output, but later shallow scrub is run over it.
Then we are losing out on the output.

rados list-inconsistent-obj 4.10
[]

Actual results:
Overwriting the deep-scrub output

Expected results:
Should not overwrite

Additional info:

Comment 2 Samuel Just 2016-04-26 14:53:54 UTC
Kefu: I thought it always deep scrubs if the stats listed a deep scrub error.

Comment 4 Kefu Chai 2016-05-10 07:40:34 UTC
Not a blocker - recommend moving to 2.z

Comment 7 Kefu Chai 2016-06-14 11:07:23 UTC
> When performing shallow scrubbing after deep scrubbing, statistics from deep scrubbing are overwritten by statistics from shallow scrubbing. As a consequence, the deep scrubbing statistics are lost.

they are not statistics, they are scrub results which document the inconsistent object and related information. other than this, looks good.

> Also, is there any workaround?

not yet.

Comment 34 errata-xmlrpc 2017-06-19 13:25:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.