Bug 1437916 - [Tracker] Release Notes tracker bug for RHCS 2.3 release
Summary: [Tracker] Release Notes tracker bug for RHCS 2.3 release
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 2.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Erin Donnelly
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On: 1418606 1200967 1265435 1330023 1330952 1351366 1370301 1370331 1391650 1391920 1396956 1397937 1408848 1416575 1418235 1420328 1421819 1423402 1423858 1423886 1425115 1435851 1436752 1438895 1438965 1439917 1446665 1451349 1451786 1458007 1458024 1458512 1459967 1461367 1464268 1464554 1465446 1469355 1477311
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-31 12:45 UTC by Anjana Suparna Sriram
Modified: 2017-08-18 02:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-02 09:55:32 UTC


Attachments (Terms of Use)

Description Anjana Suparna Sriram 2017-03-31 12:45:00 UTC
This tracker bug is not a tracker just for known issues but for every change that should appear in the Release Notes - major updates, technical previews, deprecated functions, and so on.

If there is a change that does not have a separate bug (for example it is a change introduced in a rebase), add that rebase bug as a blocker and specify the nature of the change in the doc text field of that bug.

**How to let us know that a bug should be documented in the Release Notes**

1) Add the BZ number of the bug that needs to be documented to the "Depends On" field in the Release Notes tracker bug. Alternatively, add the tracker bug BZ number to the "Blocks" field in the bug that needs to be documented.

2) In the bug that needs to be documented, set the doc type to one of the following:

* bug fix - for notable bug fixes that have significant impact on customers

* enhancement - for new features and major enhancements, RFE bugs

* technology preview - for new features shipped as tech previews

* known issues - for the known issues found in this release

3) In the bug that needs to be documented, fill in the Doc Text field with the initial information. Use the template that is in the field.

----

**Candidates for inclusion**

* Bugs with a customer case attached

* Major new features and enhancements

* Bugs with significant impact on users

* Urgent or high priority bugs

* Fixed known issues

----

**How a good initial description looks like**

* Use the cause-consequence-fix-result (CCFR) format for bug fixes:

  Cause – what user action or circumstances trigger this bug 
    
  Consequence – what the user experiences when the bug occurs 
   
  Fix – what has been changed to fix the bug (overly technical details are not necessary)
    
  Result – what happens now with the fix applied

* Use the feature-reason-result (FFR) format for major updates:

    Feature – describes the enhancement from the user's point of view
    
    Reason – why was the enhancement implemented
    
    Result – what is the current user experience (may also be compared to the previous user experience)

More info with examples: http://10.34.3.139:8080/job/Errata_Lore%20(html-single)/lastStableBuild/artifact/tmp/en-US/html-single/index.html#ccfr

----

**I want to document a change that does not have bug - how to do it?**

Add a comment here, we will add that description manually.


Note You need to log in before you can comment on or make changes to this bug.