Bug 133062 - libdb_cxx-4.0.so vanished from compat-db
Summary: libdb_cxx-4.0.so vanished from compat-db
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-db
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-21 13:26 UTC by Doncho Gunchev
Modified: 2014-03-17 02:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-22 19:42:33 UTC


Attachments (Terms of Use)

Description Doncho Gunchev 2004-09-21 13:26:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
    With compat-db-4.1.25-2.1 I had libdb_cxx-4.0.so and some
programs, for example xca (xca.sf.net), were working. The new version
(4.1.25-5) does not ship this file and some apps can not work/install.

Version-Release number of selected component (if applicable):
4.1.25-5

How reproducible:
Always

Steps to Reproduce:
1. Install FC3-t1, ls -al '/usr/lib/libdb_cxx-4.0.so'
2. update to compat-db-4.1.25-5
3. ls -al '/usr/lib/libdb_cxx-4.0.so'


Actual Results:  nothing there

Expected Results:  libdb_cxx-4.0 present

Additional info:

The changelog says that 3.1 and 3.2 are removed, but nothing about
4.0. I hope it stays for now...

Comment 1 Bill Nottingham 2004-09-22 19:38:36 UTC
* Mon Sep 13 2004 Bill Nottingham <notting@redhat.com>
- return of db1 to compat-db
- remove: db-3.1, db-3.2
- remove: c++, tcl sublibraries

See the last part of the changelog. It's intentional; it allows the
package to actually build with the current sets of compilers.


Comment 2 Doncho Gunchev 2004-10-15 13:18:12 UTC
    Yes, I agree. XCA's configure script was looking only for
libdb_cxx-4.0.so (and older). I tweaked it a bit and it works fine
now. Thanks.

Comment 3 Daniel L. Rall 2005-02-14 22:57:21 UTC
Loosely related to bug 148028.

Comment 4 Dan Williams 2005-02-17 04:00:15 UTC
Um, Bill, OOo kind of needs that compat C++ library to build and
run...  now either we rebuild OOo (which we can do in an update soon),
or we add the compat-db C++ library back in.  There has to be a way to
better deal with this kind of thing before we end up breaking stuff
out of the blue.

Comment 5 Bill Nottingham 2005-02-18 21:39:32 UTC
In what context does it need the *compat* libdb to build?

Comment 6 Bill Nottingham 2005-02-18 21:40:56 UTC
Note that the libdb_cxx mentioned here is for db-4.0, i.e., the system
DB library for RHL9. It's not the one from any current db release; it
was removed because it *would not build* on FC3; basically, at the
point it was removed, you couldn't build against it anyway.


Note You need to log in before you can comment on or make changes to this bug.