Bug 148028 - OpenOffice.org uninstallable after updating to db4.3 due to incomplete "compat" RPM
OpenOffice.org uninstallable after updating to db4.3 due to incomplete "compa...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compat-db (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 17:28 EST by Daniel L. Rall
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 22:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel L. Rall 2005-02-14 17:28:25 EST
Description of problem:

After updating to db4.3, missing compatilibity libraries which one
would be expected to be installed by the compat-db-4.2 RPM.  This
completely breaks my office suite!


Version-Release number of selected component (if applicable):

db4-4.3.21-1
compat-db-4.2.52-2

openoffice.org-1.1.2-10
openoffice.org-libs-1.1.2-10
openoffice.org-i18n-1.1.2-10


Steps to Reproduce:
1. Install db4.3 and compat-db-4.2.52-2, and associated cascade of
dependencies.
2. Attempt to re-install openoffice.org RPM (uninstalled by apt-get
dist-upgrade).

  
Actual results:

Attempting to install openoffice.org produces a long list of broken
package dependencies.  Attempting to install only openoffice.org-libs
narrows things down a bit.

$ sudo apt-get -f install openoffice.org-libs
...
The following packages have unmet dependencies:
  openoffice.org-libs: Depends: libdb_cxx-4.2.so
E: Broken packages


Expected results:

openoffice.org-libs would be installable due to the libdb_cxx-4.2.so
which _should_ be provided by the compat-db package.  db4.3 provides
/usr/lib/libdb_cxx-4.3.so (as db4.2 provided
/usr/lib/libdb_cxx-4.2.so); one would think that compatibility would
be achievable.


Additional info:

Rolling back db4.3 to db4.2 is non-trivial at this point due to the
dependency cascade of installing it in the first place:
dlr@despot:lib$ sudo rpm -e db4-4.3.21-1
error: Failed dependencies:
        libdb-4.3.so is needed by (installed) db4-utils-4.3.21-1.i386
        libdb-4.3.so is needed by (installed) python-2.4-0.c1.1.i386
        libdb-4.3.so is needed by (installed) webalizer-2.01_10-26.i386
        libdb-4.3.so is needed by (installed) postfix-2.1.5-4.1.i386
        libdb-4.3.so is needed by (installed) php-5.0.2-8.i386
        libdb-4.3.so is needed by (installed) perl-5.8.5-10.i386
        libdb-4.3.so is needed by (installed) libtabe-0.2.6-12.i386
        libdb-4.3.so is needed by (installed) httpd-2.0.52-6.i386
        libdb-4.3.so is needed by (installed) apr-util-0.9.5-1.i386
        db4 = 4.3.21-1 is needed by (installed) db4-utils-4.3.21-1.i386
        db4 = 4.3.21-1 is needed by (installed) db4-devel-4.3.21-1.i386
        db4 >= 4.1 is needed by (installed) libtabe-0.2.6-12.i386
        db4 = 4.3.21 is needed by (installed) pam-0.78-1.i386
Comment 1 Daniel L. Rall 2005-02-14 17:46:09 EST
Afflicted FC3 machine:
$ rpm -ql compat-db-4.2.52-2
/lib/libdb-4.1.so
/lib/libdb-4.2.so
[...trimmed binaries and docs, no other libs provided...]

Not-yet-upgraded FC3 machine:
$ rpm -ql db4-4.2.52-6
/lib/libdb-4.2.so
/lib/tls/i486/libdb-4.2.so
/lib/tls/i586/libdb-4.2.so
/lib/tls/i686/libdb-4.2.so
/usr/lib/libdb-4.2.so
/usr/lib/libdb_cxx-4.2.so
/usr/lib/tls/i486/libdb-4.2.so
/usr/lib/tls/i486/libdb_cxx-4.2.so
/usr/lib/tls/i586/libdb-4.2.so
/usr/lib/tls/i586/libdb_cxx-4.2.so
/usr/lib/tls/i686/libdb-4.2.so
/usr/lib/tls/i686/libdb_cxx-4.2.so
[...trimmed docs...]
$ ls -la /lib/libdb-4.2.so /usr/lib/libdb_cxx-4.2.so
-rwxr-xr-x  1 root root 843996 Sep 21 16:55 /lib/libdb-4.2.so*
-rwxr-xr-x  1 root root 919576 Sep 21 16:55 /usr/lib/libdb_cxx-4.2.so*

As you can see, the compat binary is clearly missing the C++ version.
Comment 2 Daniel L. Rall 2005-02-14 17:56:52 EST
This is loosely related to bug 133062, where Bill Nottingham comments
that the C++ library was purposely removed to allow "the package to
actually build with the current sets of compilers."  If that applies
to compat-db-4.2 as well, this bug should not be closed -- the symptom
of a failure to install openoffice.org persists.  Perhaps its more of
a packaging issue for that RPM (e.g. openoffice.org-libs.spec file
should gracefully handle db4.2 and db4.3 if compat-db isn't going to
provide a C++ version).
Comment 3 Daniel L. Rall 2005-02-14 18:22:22 EST

*** This bug has been marked as a duplicate of 139822 ***
Comment 4 Daniel L. Rall 2005-02-14 20:09:31 EST
As noted in bug 139822, the openoffice.org packages available from
RawHide (FC development) correct this problem for me.  This bug would
be more rightly filed against the "openoffice.org" Component, but I'll
leave it here just in case anyone comes in through the same path as I
as a pointer to the Right Place.
Comment 5 Matthew Miller 2006-07-10 18:34:10 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 6 R P Herrold 2006-07-14 22:57:36 EDT
it looks as though Matt missed tagging the bug close state - fixing as
currentrelease, as openoffice install bugs of that vintage are of historical
interest only at this point
Comment 7 Matthew Miller 2006-07-14 22:59:45 EDT
Yeah. Thanks!

Note You need to log in before you can comment on or make changes to this bug.