This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 133065 - system-config-soundcard, ValueError: unpack list of wrong size
system-config-soundcard, ValueError: unpack list of wrong size
Status: CLOSED DUPLICATE of bug 132300
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 09:52 EDT by Omar Ghanchi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omar Ghanchi 2004-09-21 09:52:03 EDT
Description of problem: When running system-config-soundcard the 
following error occurs from command line, "ValueError: unpack list of 
wrong size"


Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.8-1.noarch.rpm
SBLive soundcard

How reproducible:

Steps to Reproduce:
1. su
2. run system-config-soundcard
3.
  
Actual results: The following error in command line:

 system-config-soundcard
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-
soundcard.py", line 46, in 

?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in 
__init__
    self.device, self.module, self.maker, self.model = 

self.soundcardBackend.getData(card)
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 
98, in 

getData
    maker, model = string.split(description, "|")
ValueError: unpack list of wrong size


Expected results:

soundcard detection gui should start.


Additional info:

Installed FC3T2 with customized packages. Same results
Installed FC3T2 with default package selection. Same results
Removed system-config-soundcard-1.2.8-1.noarch.rpm and reinstalled 
with yum. Same results.
Rebooted several times. Same results.
Comment 1 J.Jansen 2004-09-21 16:57:02 EDT
I got exactly the same with the onboard soundcard on the asus p4p800
motherboard and FC3T2. The standard installation of FC3T1 does sound
correctly.

note that the smae problem was reported also in bug #133139

                Jouk

Comment 2 J.Jansen 2004-09-21 17:30:21 EDT
The simple solution is to upgrade the system-config-soundcard package
to 1.2.9.
     Jouk
Comment 3 Bastien Nocera 2004-09-22 12:01:52 EDT

*** This bug has been marked as a duplicate of 132300 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:05:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.