Bug 1330711 - Build golang for AArch64 in RHEL7.3
Summary: Build golang for AArch64 in RHEL7.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: golang
Version: 7.3
Hardware: aarch64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Čajka
QA Contact: Martin Cermak
URL:
Whiteboard:
: 1268554 1270119 (view as bug list)
Depends On: 1292956
Blocks: epel7aarch64 1250216 1254407 1268554 1268561 1270119 1277314 1344553 1344554 1344590 1344592 1344593 1344596 1344598
TreeView+ depends on / blocked
 
Reported: 2016-04-26 18:30 UTC by Jon Masters
Modified: 2016-11-04 01:35 UTC (History)
8 users (show)

Fixed In Version: golang-1.6.2-1.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-11-04 01:35:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2245 normal SHIPPED_LIVE golang bug fix update 2016-11-03 13:29:50 UTC

Description Jon Masters 2016-04-26 18:30:49 UTC
Description of problem:

Current builds of golang are not including aarch64 support among the available hardware targets. An agreement has been reached internally that we will build golang for aarch64 in addition. This does not mean that we will build any of the other dependencies for Atomic Host or other layered Red Hat products.

Version-Release number of selected component (if applicable):

1.6-1.el7

How reproducible:

N/A

Steps to Reproduce:

1. N/A

Actual results:

The package is not built for aarch64

Expected results:

The package should be built for aarch64

Additional info:

Comment 2 Yaakov Selkowitz 2016-05-03 20:59:27 UTC
Is ppc64/ppc64le enablement being discussed as well?  Is there a separate bz for that or should this cover both?

Comment 4 Kevin Stansell 2016-05-17 16:00:14 UTC
*** Bug 1270119 has been marked as a duplicate of this bug. ***

Comment 5 huhuang 2016-05-26 18:44:30 UTC
*** Bug 1268554 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2016-11-04 01:35:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2245.html


Note You need to log in before you can comment on or make changes to this bug.