Bug 1292956 - REBASE to golang 1.6
REBASE to golang 1.6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: golang (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jakub Čajka
Martin Cermak
: Extras, Rebase, ZStream
: 1292951 (view as bug list)
Depends On:
Blocks: 1330711 1346331
  Show dependency treegraph
 
Reported: 2015-12-18 15:23 EST by Timothy St. Clair
Modified: 2016-11-03 21:35 EDT (History)
20 users (show)

See Also:
Fixed In Version: golang-1.6-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: 1.6.2 Golang package has been rebased to version 1.6.2 Highlights, important fixes, or notable enhancements:
Story Points: ---
Clone Of:
: 1346331 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:35:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2245 normal SHIPPED_LIVE golang bug fix update 2016-11-03 09:29:50 EDT

  None (edit)
Description Timothy St. Clair 2015-12-18 15:23:30 EST
Description of problem:
Update golang b/c there have been significant performance improvements that are desired for openshift.  


Actual results:
$go version
go version go1.4.2 linux/amd64

Expected results:
$go version
go version go1.4.2 linux/amd64

Additional info:
I believe there are may be some existing golang issues on encryption that may apply.
Comment 2 Scott Dodson 2015-12-18 16:12:45 EST
*** Bug 1292951 has been marked as a duplicate of this bug. ***
Comment 5 Jordan Liggitt 2016-01-04 11:20:31 EST
The testcase at http://play.golang.org/p/zpXKadV5mo is what we're hoping to pick up a fix for
Comment 6 Jakub Čajka 2016-01-05 09:31:41 EST
(In reply to Jordan Liggitt from comment #5)
> The testcase at http://play.golang.org/p/zpXKadV5mo is what we're hoping to
> pick up a fix for

So it is issue tracked by BZ1290472 (If I didn't overlooked anything, it is same reproducer). Could you please confirm that for a clarity and a record?

Just elaborate bit on BZ#1290472 assuming confirmation. It is separate issue tracked by the up mentioned BZ with no direct relation(aside it affects all currently released golang versions) to golang version/rebase(it will be/is "fixed" by upstream in upcoming upstream 1.6 release, and it has been fixed in Fedora see BZ1290543).
Comment 7 Timothy St. Clair 2016-01-06 11:43:32 EST
Primary driver on our end are the performance changes, and upstream k8s support.  gc-performance has substantially been improved.
Comment 8 Yaakov Selkowitz 2016-01-06 12:46:56 EST
Rebasing to 1.5 would also allow enablement on aarch64.
Comment 13 Timothy St. Clair 2016-01-13 21:45:29 EST
Make that golang 1.5.3 - recently release CVE as of today. 

https://groups.google.com/forum/#!topic/golang-announce/MEATuOi_ei4
Comment 27 Timothy St. Clair 2016-03-23 09:57:07 EDT
Upstream kubernetes golang 1.6 issue for tracking:  https://github.com/kubernetes/kubernetes/pull/22149
Comment 42 errata-xmlrpc 2016-11-03 21:35:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2245.html

Note You need to log in before you can comment on or make changes to this bug.