Bug 13318 - X locked up.
X locked up.
Status: CLOSED DUPLICATE of bug 13054
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-01 18:25 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-03 14:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2000-07-01 18:25:51 EDT
Came back after being away from the machine for an hour, X was locked up,
and eating CPU time.

strace of the X process:

[ ... ]

sigreturn()                             = ? (mask now [CHLD])
--- SIGVTALRM (Virtual timer expired) ---
sigreturn()                             = ? (mask now [CHLD])
--- SIGVTALRM (Virtual timer expired) ---
sigreturn()                             = ? (mask now [CHLD])
--- SIGVTALRM (Virtual timer expired) ---
sigreturn()                             = ? (mask now [CHLD])
--- SIGVTALRM (Virtual timer expired) ---
sigreturn()                             = ? (mask now [CHLD])
--- SIGVTALRM (Virtual timer expired) ---
sigreturn()                             = ? (mask now [CHLD])
--- SIGVTALRM (Virtual timer expired) ---

[ ... ]

... ad infinitum.

Had to kill -9 it.
Comment 1 Bill Nottingham 2000-07-03 01:11:48 EDT
Was any screensaver running (if so , which one?)
Comment 2 Sam Varshavchik 2000-07-03 14:45:32 EDT
Yes, it most probably was -- the machine was left alone for an extended period
of time.  I couldn't tell which particular screensaver was running.

Comment 3 Bill Nottingham 2000-07-03 18:52:37 EDT

*** This bug has been marked as a duplicate of 13054 ***

Note You need to log in before you can comment on or make changes to this bug.