Bug 13054 - xscreensaver freezing my machine?
xscreensaver freezing my machine?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 12256 13318 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-26 10:29 EDT by Tim Powers
Modified: 2014-03-16 22:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-20 12:45:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-06-26 10:29:56 EDT
I haven't done further testing, but here goes. Xscreensaver seems to lock
up the machine when it blanks the screen. The machine has to be reset. I
couldn't test to see if I could get into it remotely since I don't have any
networked machines at home at the moment. Removing xscreensaver &
kdebase-3d-screensavers fixes the problem (machine doesn't have a blank
screen and won't lock up).
Comment 1 Red Hat Bugzilla 2000-07-03 18:52:35 EDT
*** Bug 13318 has been marked as a duplicate of this bug. ***
Comment 2 Red Hat Bugzilla 2000-07-06 16:56:48 EDT
*** Bug 12256 has been marked as a duplicate of this bug. ***
Comment 3 Red Hat Bugzilla 2000-07-08 15:13:53 EDT
This should be fixed in XFree86-4.0-0.32.
(FWIW, the XFree86-Servers packages also needs to be rebuilt.)
Comment 4 Red Hat Bugzilla 2000-07-18 16:58:51 EDT
I saw this on beta3.  Was the fix supposed to be in beta3?  It hung on a moire
pattern and I totally lost control of the mouse and keyboard. 
Ctrl-Alt-Backspace and Ctrl-Alt-Delete did nothing.  I had a couple of rlogin
sessions going to it and they were fine.  I tried to kill the X-server.  It died
but the screen didn't change and I didn't get control of my keyboard or mouse
back.  I had to issue a shutdown and reboot.
Comment 5 Red Hat Bugzilla 2000-07-18 17:00:23 EDT
No, it was fixed shortly after beta3.
Comment 6 Red Hat Bugzilla 2000-07-18 19:14:32 EDT
So, the latest xscreensaver package should fix this?
Comment 7 Red Hat Bugzilla 2000-07-18 19:19:06 EDT
No, you need a newer XFree86 or XFree86-Servers package. The compiler
was miscompiling part of the X server.
Comment 8 Red Hat Bugzilla 2000-07-19 13:46:29 EDT
Are these in rawhide?  I looked in
ftp://beta.redhat.com/pub/rawhide/i386/RedHat/RPMS/ and I seem to already have
the latest version of everything:

XFree86-4.0.1-0.30
XFree86-devel-4.0.1-0.30
XFree86-libs-4.0.1-0.30
XFree86-tools-4.0.1-0.30
XFree86-Mach64-3.3.6-30

These version numbers seem to match what is in rawhide.
Comment 9 Red Hat Bugzilla 2000-07-20 12:45:15 EDT
No response to above comment so re-opening...
Comment 10 Red Hat Bugzilla 2000-07-20 13:07:08 EDT
They will be fixed in beta4/ the next rawhide release.
Comment 11 Red Hat Bugzilla 2001-05-02 17:02:45 EDT
This problem may still exist. When I upgraded from 7.0 to 7.1 it appeared. A
work-around seems to be to rename your old .xscreensaver file out of the way,
let it create a new one, and re-do your preferences.

Note You need to log in before you can comment on or make changes to this bug.