Bug 133193 - wget displays bogus file sizes, fails to download
Summary: wget displays bogus file sizes, fails to download
Status: CLOSED DUPLICATE of bug 123524
Alias: None
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
: 133350 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-22 12:45 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug fix patch (290 bytes, patch)
2004-09-27 18:26 UTC, Jason Duerstock
no flags Details | Diff
no, really, this fixes it, honest (541 bytes, patch)
2004-09-27 18:31 UTC, Jason Duerstock
no flags Details | Diff

Description Ralf Ertzinger 2004-09-22 12:45:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
wget displays bogus remote file sizes and fails to download remote
files (only HTTP tested, not every server). Example of failure:

[sun@nausicaa ~ :) 7]$ wget
http://ftp.ie.freshrpms.net/pub/fedora/linux/core/development/i386/GPL
--14:37:31-- 
http://ftp.ie.freshrpms.net/pub/fedora/linux/core/development/i386/GPL
           => `GPL'
Resolving ftp.ie.freshrpms.net... 193.1.219.82
Connecting to ftp.ie.freshrpms.net[193.1.219.82]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: B,446,744,069,414,602,705 [text/plain]

    [ <=>                                                            
                        ] 0             --.--K/s             

14:37:32 (0.00 B/s) - `GPL' saved [0/0])

The file created is empty.

Version-Release number of selected component (if applicable):
wget-1.9.1-16

How reproducible:
Always

Steps to Reproduce:
1. use wget to download a http file
2.
3.
    

Actual Results:  Bogus file size (always), download fails (sometimes)

Expected Results:  Transfer of file

Additional info:

Comment 1 Oliver Falk 2004-09-23 13:15:16 UTC
*** Bug 133350 has been marked as a duplicate of this bug. ***

Comment 2 Michel Alexandre Salim 2004-09-23 23:51:03 UTC
Confirming this on wget-1.9.1-16

Comment 3 Jason Duerstock 2004-09-27 18:26:35 UTC
Created attachment 104391 [details]
bug fix patch

fixes length problem, possibly breaks ability to reuse header_extract_number in
other places.  function doesn't appear to be called anywhere else.

Comment 4 Jason Duerstock 2004-09-27 18:31:44 UTC
Created attachment 104392 [details]
no, really, this fixes it, honest

oops, forgot to resize temporary result variable

Comment 5 Karsten Hopp 2004-09-28 14:35:54 UTC

*** This bug has been marked as a duplicate of 123524 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:05:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.