This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 133196 - Missing deps on latest yum update
Missing deps on latest yum update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 09:14 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 16:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-09-22 09:14:28 EDT
Description of problem:

[root@hoho2 ~]# yum update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3525/3525
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2 - Development Tree
Resolving Dependencies
Error: missing dep: libopenobex-1.0.so.0 for pkg libbtctl
Error: missing dep: libgcj for pkg java-1.4.2-gcj-compat
Error: missing dep: openobex for pkg openobex-apps
Error: missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Error: missing dep: libstdc++ for pkg gcc35-c++
Error: missing dep: libgfortran for pkg gcc35-gfortran
Error: missing dep: libopenobex-1.0.so.0 for pkg openobex-apps
Error: missing dep: libstdc++-devel for pkg gcc35-c++
[root@hoho2 ~]#

Version-Release number of selected component (if applicable):

  up2date (apparently) except for noted components.

How reproducible:

  The last 3 or 4 tries - after reboots too.

Steps to Reproduce:
1.  yum update
2.
3.
  
Actual results:

  see above

Expected results:

  clean update

Additional info:

  getenforce -> Permissive
Comment 1 Bob Gustafson 2004-09-23 01:48:48 EDT
This is sort of similar to the condition reported in bug 126681

One of the fixes suggested there was to rebuild the rpm database

[root@hoho2 ~]# rpm --rebuilddb

[root@hoho2 ~]# yum update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3500/3500
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2 - Development Tree
Resolving Dependencies
Error: missing dep: libopenobex-1.0.so.0 for pkg libbtctl
Error: missing dep: libstdc++ for pkg gcc35-c++
Error: missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Error: missing dep: openobex for pkg openobex-apps
Error: missing dep: libgfortran for pkg gcc35-gfortran
Error: missing dep: libgcj for pkg java-1.4.2-gcj-compat
Error: missing dep: libstdc++-devel for pkg gcc35-c++
[root@hoho2 ~]#

As in that bug, rpm --rebuilddb did not solve it.
Comment 2 Bob Gustafson 2004-09-24 16:48:34 EDT
With some hand work, I was able to get rid of all of the 'missing dep'
messages.

It is really pretty simple - just erase all of the complaining
components as in 'rpm -e -nodeps gcc35-c++'

Once you have a clean 'yum update', then the erased components can be
manually installed as in 'yum install libbtctl'

You many notice that some of the components have gone away (e.g., the
gcc35...) in favor of newer (gcc4).

However, some of the missing deps are still missing, as in 

[root@hoho2 user1]# yum install gnome-bluetooth
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3500/3500
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2 - Development Tree
Resolving Dependencies
Restarting Dependency Process with new changes
Error: missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Error: missing dep: libopenobex-1.0.so.0 for pkg libbtctl
[root@hoho2 user1]#

I guess it Works For Me

Note You need to log in before you can comment on or make changes to this bug.