Bug 1332146 - FTBFS: dfu_firmware_dfu_func: assertion failed
Summary: FTBFS: dfu_firmware_dfu_func: assertion failed
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fwupd
Version: 24
Hardware: ppc64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1335823 (view as bug list)
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-05-02 11:20 UTC by Karsten Hopp
Modified: 2016-05-16 16:18 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-16 16:18:26 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2016-05-02 11:20:42 UTC
Description of problem:
/libdfu/firmware{raw}: OK
/libdfu/firmware{dfu}: **
libdfu:ERROR:dfu-self-test.c:213:dfu_firmware_dfu_func: assertion failed (error == NULL): CRC failed, expected d4dc86d4, got d486dcd4 (DfuError, 0)
FAIL /builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test (exit status: 134)
============================================================================
Testsuite summary for fwupd 0.7.0
============================================================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See libdfu/test-suite.log
Please report to https://github.com/hughsie/fwupd

Version-Release number of selected component (if applicable):
fwupd-0.7.0-1.fc24


Steps to Reproduce:
1. ppc-koji build --scratch f24 fwupd-0.7.0-1.fc24.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3342467

Comment 1 Dan Horák 2016-05-02 11:30:11 UTC
I've just looked on it too and it has been fixed in upstream - https://github.com/hughsie/fwupd/issues/43

Comment 2 Dan Horák 2016-05-13 10:03:33 UTC
*** Bug 1335823 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2016-05-13 14:44:04 UTC
fwupd-0.7.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-363e01592c

Comment 4 Fedora Update System 2016-05-15 06:56:57 UTC
fwupd-0.7.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-363e01592c

Comment 5 Fedora Update System 2016-05-16 16:18:23 UTC
fwupd-0.7.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.