Bug 1335823 - fwupd 0.7 tests fail on big endian platforms in libdfu tests
Summary: fwupd 0.7 tests fail on big endian platforms in libdfu tests
Status: CLOSED DUPLICATE of bug 1332146
Alias: None
Product: Fedora
Classification: Fedora
Component: fwupd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-05-13 10:01 UTC by Peter Robinson
Modified: 2016-05-13 10:03 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-13 10:03:33 UTC


Attachments (Terms of Use)

Description Peter Robinson 2016-05-13 10:01:47 UTC
Not sure if this is an endian issue with fwupd or libdfu (although looks like the later is a bundled/internal library anyway)

ppc64: http://ppc.koji.fedoraproject.org/koji/packageinfo?packageID=19765
s390x: http://s390.koji.fedoraproject.org/koji/packageinfo?packageID=19775

Making check in libdfu
make[1]: Entering directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
make  dfu-self-test
make[2]: Entering directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
gcc -DHAVE_CONFIG_H -I. -I..  -pthread -I/usr/include/libappstream-glib -I/usr/include/libgcab-1.0 -I/usr/include/uuid -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gusb-1 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libusb-1.0 -fPIE -I../libdfu -I.. -I.. -DG_USB_API_IS_SUBJECT_TO_CHANGE -DG_LOG_DOMAIN=\"libdfu\" -DTESTDATADIR=\""../data/tests/dfu"\" -DLOCALEDIR=\""/usr/share/locale"\"  -DEGG_TEST  -Wall -Wcast-align -Wno-uninitialized -Wmissing-declarations -Wpointer-arith -Wcast-align -Wwrite-strings -Winit-self -Wreturn-type -Wformat-nonliteral -Wformat-security -Wmissing-include-dirs -Wmissing-format-attribute -Wclobbered -Wempty-body -Wignored-qualifiers -Wsign-compare -Wtype-limits -Wuninitialized -Waggregate-return -Wdeclaration-after-statement -Wshadow -Wno-strict-aliasing -Winline -Wmissing-parameter-type -Woverride-init -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -c -o dfu_self_test-dfu-self-test.o `test -f 'dfu-self-test.c' || echo './'`dfu-self-test.c
/bin/sh ../libtool  --tag=CC   --mode=link gcc -DEGG_TEST  -Wall -Wcast-align -Wno-uninitialized -Wmissing-declarations -Wpointer-arith -Wcast-align -Wwrite-strings -Winit-self -Wreturn-type -Wformat-nonliteral -Wformat-security -Wmissing-include-dirs -Wmissing-format-attribute -Wclobbered -Wempty-body -Wignored-qualifiers -Wsign-compare -Wtype-limits -Wuninitialized -Waggregate-return -Wdeclaration-after-statement -Wshadow -Wno-strict-aliasing -Winline -Wmissing-parameter-type -Woverride-init -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64  -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o dfu-self-test dfu_self_test-dfu-self-test.o libdfu.la -lgthread-2.0 -pthread -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lgusb -lgobject-2.0 -lglib-2.0 -lusb-1.0 
libtool: link: gcc -DEGG_TEST -Wall -Wcast-align -Wno-uninitialized -Wmissing-declarations -Wpointer-arith -Wcast-align -Wwrite-strings -Winit-self -Wreturn-type -Wformat-nonliteral -Wformat-security -Wmissing-include-dirs -Wmissing-format-attribute -Wclobbered -Wempty-body -Wignored-qualifiers -Wsign-compare -Wtype-limits -Wuninitialized -Waggregate-return -Wdeclaration-after-statement -Wshadow -Wno-strict-aliasing -Winline -Wmissing-parameter-type -Woverride-init -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -Wl,-z -Wl,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o .libs/dfu-self-test dfu_self_test-dfu-self-test.o -pthread -Wl,--export-dynamic -pthread  ./.libs/libdfu.so -lm -lgthread-2.0 -lgio-2.0 -lgmodule-2.0 -lgusb -lgobject-2.0 -lglib-2.0 -lusb-1.0 -pthread
make[2]: Leaving directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
make  check-TESTS
make[2]: Entering directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
make[3]: Entering directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
../test-driver: line 107:  6472 Aborted                 (core dumped) "$@" > $log_file 2>&1
FAIL: /builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test
========================================
   fwupd 0.7.0: libdfu/test-suite.log
========================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
.. contents:: :depth: 2
FAIL: dfu-self-test
===================
/libdfu/enums: OK
/libdfu/target(DfuSe}: (/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Flash3
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: 
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Internal Flash
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: Zone:0, Sec#:0, Addr:0x08000000, Size:0x0400, Caps:0x1
Zone:0, Sec#:0, Addr:0x08000400, Size:0x0400, Caps:0x1
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Flash1
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: Zone:0, Sec#:0, Addr:0x08000000, Size:0x0400, Caps:0x1
Zone:0, Sec#:0, Addr:0x08000400, Size:0x0400, Caps:0x1
Zone:0, Sec#:1, Addr:0x08000000, Size:0x0400, Caps:0x7
Zone:0, Sec#:1, Addr:0x08000400, Size:0x0400, Caps:0x7
Zone:0, Sec#:1, Addr:0x08000800, Size:0x0400, Caps:0x7
Zone:0, Sec#:1, Addr:0x08000c00, Size:0x0400, Caps:0x7
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Flash2
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: Zone:0, Sec#:0, Addr:0x0000f000, Size:0x0064, Caps:0x1
Zone:0, Sec#:0, Addr:0x0000f064, Size:0x0064, Caps:0x1
Zone:0, Sec#:0, Addr:0x0000f0c8, Size:0x0064, Caps:0x1
Zone:0, Sec#:0, Addr:0x0000f12c, Size:0x0064, Caps:0x1
Zone:1, Sec#:0, Addr:0x0000e000, Size:0x2000, Caps:0x7
Zone:1, Sec#:0, Addr:0x00010000, Size:0x2000, Caps:0x7
Zone:1, Sec#:0, Addr:0x00012000, Size:0x2000, Caps:0x7
Zone:2, Sec#:0, Addr:0x00080000, Size:0x6000, Caps:0x7
Zone:2, Sec#:0, Addr:0x00086000, Size:0x6000, Caps:0x7
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Internal Flash
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Internal Flash
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: DfuSe nice alt-name: Flash|XTEA
(/builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test:6472): libdfu-DEBUG: 
OK
/libdfu/firmware{raw}: OK
/libdfu/firmware{dfu}: **
libdfu:ERROR:dfu-self-test.c:213:dfu_firmware_dfu_func: assertion failed (error == NULL): CRC failed, expected d4dc86d4, got d486dcd4 (DfuError, 0)
FAIL /builddir/build/BUILD/fwupd-0.7.0/libdfu/.libs/lt-dfu-self-test (exit status: 134)
============================================================================
Testsuite summary for fwupd 0.7.0
============================================================================
# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See libdfu/test-suite.log
Please report to https://github.com/hughsie/fwupd
============================================================================
Makefile:1210: recipe for target 'test-suite.log' failed
make[3]: *** [test-suite.log] Error 1
make[3]: Leaving directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
Makefile:1316: recipe for target 'check-TESTS' failed
make[2]: *** [check-TESTS] Error 2
make[2]: Leaving directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
Makefile:1389: recipe for target 'check-am' failed
make[1]: *** [check-am] Error 2
make[1]: Leaving directory '/builddir/build/BUILD/fwupd-0.7.0/libdfu'
Makefile:549: recipe for target 'check-recursive' failed
make: *** [check-recursive] Error 1

Comment 1 Dan Horák 2016-05-13 10:03:33 UTC

*** This bug has been marked as a duplicate of bug 1332146 ***


Note You need to log in before you can comment on or make changes to this bug.