Bug 133236 - Kernel parameter root= is ignored
Kernel parameter root= is ignored
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 133191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 13:56 EDT by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-26 23:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-09-22 13:56:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
If I change the root= option in /boot/grub/grub.conf the system boot will not be affected.

The ./init script in the initrd has the root device hard-coded thus making it impossible to use the same initrd for booting with a different device.

Version-Release number of selected component (if applicable):
4.1.11-1

How reproducible:
Always

Steps to Reproduce:
Boot with "root=whatever" and observe that it makes no difference.

Additional info:
Comment 1 Jeremy Katz 2004-09-22 14:00:57 EDT
It shouldn't have it hard-coded, it should have it as /dev/root but
that gets dynamically created.  Or does your initrd have something else?
Comment 2 Russell Coker 2004-09-22 14:10:58 EDT
echo Mounting root filesystem 
mount -o defaults --ro -t ext3 /dev/mapper/fc_test-strict /sysroot 
 
The above is from the /init file in the initrd.  Below are both 
instances of the root mount command from /sbin/mkinitrd.  Lines 732 
and 743. 
 
echo "echo Mounting root filesystem" >> $RCFILE 
echo "mount -o $rootopts --ro -t $rootfs $rootdev /sysroot">>$RCFILE 
 
echo "echo Mounting root filesystem" >> $RCFILE 
echo "mount -o $rootopts --ro -t $rootfs $rootdev /sysroot">>$RCFILE 
 
Comment 3 Jeremy Katz 2004-09-24 13:00:47 EDT
*** Bug 133191 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2004-09-30 18:06:07 EDT
Should be fixed in 4.1.14
Comment 5 Russell Coker 2006-03-26 23:54:10 EST
This has been fixed for long enough, FC3 is not supported any more so there's 
no reason to keep the bug open. 

Note You need to log in before you can comment on or make changes to this bug.