Bug 133310 - Missing many control-center preferences from gnome menu
Summary: Missing many control-center preferences from gnome menu
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-23 02:14 UTC by Jef Spaleta
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 13:18:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jef Spaleta 2004-09-23 02:14:13 UTC
Description of problem:
As discussed in fedora-test-list
there seems to be a problemn with the desktop files for many of the
control-center tools. I'm not sure if this is a problem with
control-center or with redhat-menus package. But i'm filing against
control-center since it seems to be the primary package affected.

Right now I don't have most of the control-center tools in the gnome
preference menu. no sound,theme,network, keyboard, keybindings or
windows preference entries. I'm sure I'm missing more, but those are
the one's I've noticed. The test-list thread suggested that the
Categories are in flux and that the control-center .desktop files have
the wrong category definitions at the moment.

Also not showing up in the control-center nautilus window.

Version-Release number of selected component (if applicable):
control-center-2.7.1-4
redhat-menus-1.6.1-1

System:
fresh install of fc3t2 using workstation intall defaults
updated to currently available rawhide packages.

Comment 1 Dave Cook 2004-09-24 10:25:31 UTC
My default FC3T2 (x86-64) was fine, but I'm seeing this with
control-center 2.8.0-1.

Comment 2 Dave Cook 2004-09-24 18:42:09 UTC
Looks like it's fixed in 2.8.0-3

Comment 3 Jef Spaleta 2004-09-25 01:29:08 UTC
Not completely fixed

gnome-sessions-properties isn't showing up still
Looks like it should be in Preferences->More Preferences

but the categories are wrong. Compare
gnome-session-properties.desktop to gstreamer-properties.desktop

I think gnome-session-properties.desktop should read:
Categories=GNOME;Application;Settings;AdvancedSettings;
instead of
Categories=Application;AdvancedSettings;X-Red-Hat-Base;

-jef

Comment 4 Jef Spaleta 2004-09-25 03:03:01 UTC
gnome-default-applications  seems to be missing a menu entry now as well.

To recap with control-center-2.8.0-3
I am still missing menu entries for:
gnome-default-applications
gnome-session-properties

i just did a full comparison of the .desktop files installed by
control-center and the preference menu. Those 2 capplets are the only
2 that I can't find menu entries for.

-jef

Comment 5 Ray Strode [halfline] 2004-09-27 16:58:57 UTC
These are being moveed to More Preferences because of bug 131605

Should be fixed now.

Comment 6 Jef Spaleta 2004-09-27 17:09:01 UTC
Now as in in whats available publicly in rawhide right now?
or Now as in what's going to be available in rawhide publicly on the
next rawhide push?

I'd appreciate it greatly if you could reference a version number of
the package that has the fix, so that I as someone outside the red hat
fenceline, can be sure i'm using the correct version of control-center
when i confirm the fix is working for me.

-jef

Comment 7 Jef Spaleta 2004-09-28 13:18:58 UTC
control-center-2.8.0-7  installed and afaict all the .desktop files
are in an appropriate menu now.  I'm closing this as resolution rawhide.


Note You need to log in before you can comment on or make changes to this bug.