Bug 133315 - gedit does not print properly in zh_CN locale
Summary: gedit does not print properly in zh_CN locale
Status: CLOSED DUPLICATE of bug 131222
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libgnomeprint22   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-23 02:59 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lawrence Lim 2004-09-23 02:59:04 UTC
Description of problem:
In the zh_CN.UTF-8 locale, while printing a document with simplied
chinese content, file name and page number, the output is missing the
page number and numeric characters in the file name

Version-Release number of selected component (if applicable):
libgnomeprint22-2.7.1-7

How reproducible:
Always

Steps to Reproduce:
1.start gedit in the zh_CN locale
2.enter text in gedit
3.save file name in native text, Untitle 1 (the default name if gedit
is in the zh_CN locale)
4.print the documnent
  
Actual results:
The numeric '1' and the page numbers are missing in the printout

Expected results:
The numeric is the filename and page number should be printed

Additional info:
The printout is fine in the zh_TW locale

Comment 1 Lawrence Lim 2004-09-26 23:56:21 UTC
It has also been noted that in the ja_JP locale, katakana and hiragana
characters were printed as dots while kanji characters are printed fine.

Comment 2 Leon Ho 2004-09-27 05:41:36 UTC
Look like it is a different problem. I can reproduce the ja_JP problem
but not the zh_CN problem yet. (libgnomeprint22-2.7.1-7 on
rawhide20040923)

Comment 3 Lawrence Lim 2004-09-27 06:32:06 UTC
Creating a new on ja specifically, bug 133747.

Comment 4 Leon Ho 2004-09-27 08:00:50 UTC
I can reproduce it now. Look it is very similar to indic gnomeprint
problem - bug 131222

putting the same font size against all body, header and footer will
make it work again.

Comment 5 Owen Taylor 2004-09-27 18:29:42 UTC

*** This bug has been marked as a duplicate of 131222 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:05:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.