Bug 133326 - Yum hang and failure to download xorg dep
Yum hang and failure to download xorg dep
Status: CLOSED DUPLICATE of bug 133274
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 03:45 EDT by Kevin Olemoh
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Olemoh 2004-09-23 03:45:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
Yum hangs when executing yum update when it attempts to retrieve some
xorg font packages and the dependencies.  Specifically the xfs package
fails to download then is suddendly listed as completed and this is
what the output looks like: 


I found if I downloaded the offending package first that yum behaved
more or less properly.


Version-Release number of selected component (if applicable):
2.1.3-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Initiate a system wide update using yum update
2.
3.
    

Actual Results:  Yum hung and failed to update.

Expected Results:  expected all installed packages to be updated if
possible.

Additional info:

xorg-x11-xfs-6.8.1-3.i386  79% |===================      | 184 kB   
00:08 ETA 
dxorg-x11-xfs-6.8.1-3.i386 100% |=========================| 199 kB   
05:10     
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 139, in ?
    main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 131,
in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 151,
in resolveDeps
    self.populateTs(test=1)
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 115,
in populateTs
    hdr = po.getHeader()
  File "/usr/lib/python2.3/site-packages/yum/packages.py", line 272,
in getHeader
    hdr = hlist[0]
IndexError: list index out of range

Note that I did do an upgrade instead of a clean install.
Comment 1 Seth Vidal 2004-09-23 03:47:24 EDT
duplicate of 133274

*** This bug has been marked as a duplicate of 133274 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.