Bug 133274 - yum dies with "IndexError: list index out of range"
Summary: yum dies with "IndexError: list index out of range"
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 133326 133987 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-22 20:32 UTC by Dumitru Ciobarcianu
Modified: 2014-01-21 22:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 20:38:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dumitru Ciobarcianu 2004-09-22 20:32:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Galeon/1.3.17

Version-Release number of selected component (if applicable):
yum-2.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. Add the following lines to yum.conf:

[dag.swb.be]
name=Dag Apt Repository
baseurl=http://ftp.lug.ro/mirror/apt.sw.be/dag/fedora/2/en/i386/dag/


2. yum update:
3. yum dies
    

Actual Results:  yum dies with the following backtrace:

Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 139, in ?
    main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 131,
in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 151,
in resolveDeps
    self.populateTs(test=1)
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 115,
in populateTs
    hdr = po.getHeader()
  File "/usr/lib/python2.3/site-packages/yum/packages.py", line 272,
in getHeader
    hdr = hlist[0]
IndexError: list index out of range


Expected Results:  yum retrives updated packages.

Comment 1 Seth Vidal 2004-09-22 20:38:29 UTC
https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=297

Fixed in CVS
resolving as closed, upstream.


Comment 2 Seth Vidal 2004-09-23 07:47:37 UTC
*** Bug 133326 has been marked as a duplicate of this bug. ***

Comment 3 Seth Vidal 2004-09-28 20:41:09 UTC
*** Bug 133987 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.