Bug 1333282 - Disable new devices in QEMU 2.6
Summary: Disable new devices in QEMU 2.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Chao Yang
URL:
Whiteboard:
: 1343312 (view as bug list)
Depends On: 1235580 1289417 1333299 1333306 1333310 1333315 1333318 1337457 1337557 1343312 1343891 1347049
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-05 07:48 UTC by Miroslav Rezanina
Modified: 2016-11-07 21:06 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-17.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:06:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Miroslav Rezanina 2016-05-05 07:48:47 UTC
QEMU 2.6 introduces following devices:

allwinner-ahci
hyperv-testdev
i8257
igd-passthrough-i440FX
ipmi-bmc-extern
ipmi-bmc-sim
isa-ipmi-bt
isa-ipmi-kcs
ivshmem-doorbell
ivshmem-plain
mptsas1068
nvdimm
pci-bridge-seat
pxb-pcie
rocker
sd-card
vfio-amd-xgbe
vfio-calxeda-xgmac
virtio-gpu-device
virtio-gpu-pci
virtio-vga


By default, this devices should be disabled. In case any of them needs to be enabled, request for it has to be done in separate BZ to have it properly documented.

Comment 1 Laurent Vivier 2016-05-19 12:41:28 UTC
ppc64 introduces one more device:

spapr-rng

Comment 2 Miroslav Rezanina 2016-06-13 06:45:59 UTC
*** Bug 1343312 has been marked as a duplicate of this bug. ***

Comment 3 Marcel Apfelbaum 2016-06-23 09:23:36 UTC
Hi,

I had the impression that pxb-pcie it is already enabled but I see it in the list. Should I open a BZ for enabling it?

Thanks,
Marcel

Comment 4 Miroslav Rezanina 2016-06-23 11:02:27 UTC
Hi Marcel,
this bug mark all new devices as need to disable. Then there's bunch of blockers requesting enabling some of these devices (1333315 for pxb-pcie). This is process handling of device tree changes.

On code level, all new devices are enabled when qemu-kvm-rhev is rebased and then we disable only the devices we won't support. This way we avoid unnecessary work with disabling and re-enabling devices.

For pxb-pcie, we are going to disable command-line handling but the device itself will remain enabled (will have no-user flag).

Comment 5 Marcel Apfelbaum 2016-06-23 11:14:38 UTC
(In reply to Miroslav Rezanina from comment #4)
> Hi Marcel,
> this bug mark all new devices as need to disable. Then there's bunch of
> blockers requesting enabling some of these devices (1333315 for pxb-pcie).
> This is process handling of device tree changes.
> 
> On code level, all new devices are enabled when qemu-kvm-rhev is rebased and
> then we disable only the devices we won't support. This way we avoid
> unnecessary work with disabling and re-enabling devices.
> 
> For pxb-pcie, we are going to disable command-line handling but the device
> itself will remain enabled (will have no-user flag).

Hi, sorry for the possibly stupid question, but what do you mean "we disable the command line" ? We want to use the device, how will we do it? I am missing something here...

Thanks,
Marcel

Comment 6 Miroslav Rezanina 2016-06-23 11:26:39 UTC
As stated on irc, it should be used internaly (that was the result of internal dicussion). Anyway, more on this topic in pxb-pcie related bug.

Comment 7 Miroslav Rezanina 2016-07-29 09:11:25 UTC
Fix included in qemu-kvm-rhev-2.6.0-17.el7

Comment 15 errata-xmlrpc 2016-11-07 21:06:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.