Bug 133331 - printconf does not work with non-english locale
printconf does not work with non-english locale
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 04:41 EDT by Peter Klotz
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Klotz 2004-09-23 04:41:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
printconf does not start. The reason is line 190 in
/usr/share/printconf/util/cups_import.py:
        if l.startswith (" link currently points to"):

Running /usr/sbin/alternatives with de_DE@euro as LANG produces this
result however:
...
 Link verweist auf /usr/bin/lpr.cups
...

This should be fixed to work under all locales.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.19-1

How reproducible:
Always

Steps to Reproduce:
1. Set de_DE@euro as locale
2. Call printconf
    

Actual Results:  [root@icotanis root]# printconf
Traceback (most recent call last):
  File "/usr/sbin/printconf", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment


Expected Results:  printer configuration should start under all locales.

Additional info:

Workaround, which will start the configuration (albeit in english
language)
[root@icotanis root]# export LANG=en_US
[root@icotanis root]# printconf
Comment 1 Tim Waugh 2004-09-23 07:14:11 EDT

*** This bug has been marked as a duplicate of 131563 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.