Bug 133333 - ypbind starts after netfs - mounting network filesystems from hosts names of which are available only thorgh NIS fails.
Summary: ypbind starts after netfs - mounting network filesystems from hosts names of ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ypbind   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 52006 (view as bug list)
Depends On: 141701
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-23 08:47 UTC by Igor Truszkowski
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version: 1.17.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 04:45:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Move ypbind init from 27 to 24, directly before netfs (25) (632 bytes, patch)
2005-01-13 23:45 UTC, Nicholas Miell
no flags Details | Diff

Description Igor Truszkowski 2004-09-23 08:47:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
The problem occurs in FC1 as well. By default there is following order
in initscripts: S25netfs, S27ypbind. Therefore if in /etc/fstab
hostname  is used insted of IP address (e.g. nfsserv:/home /home nfs
auto...), and the hostname is resolvable only through NIS, netfs
script will fail to mount these filesystems.

Version-Release number of selected component (if applicable):
ypbind-1.17.2-1

How reproducible:
Always

Steps to Reproduce:
1.Reboot ;)
2.
3.
    

Additional info:

Comment 1 Nicholas Miell 2005-01-13 23:42:02 UTC
see also bug 52006

This still applies to the latest devel tree, but I lack privileges necessary to
modify the Version field.

Comment 2 Nicholas Miell 2005-01-13 23:45:24 UTC
Created attachment 109747 [details]
Move ypbind init from 27 to 24, directly before netfs (25)

This is untested. I have no idea how this change in magic numbers may or may
not break the arcane boot process that is SysVinit.

Comment 4 Chris Feist 2005-02-01 22:27:07 UTC
*** Bug 52006 has been marked as a duplicate of this bug. ***

Comment 5 Chris Feist 2005-02-01 22:59:32 UTC
I've modified the ypbind init script priorities in RHEL-3 & FC-3 &
FC-2 to S24 & K76 from S27 & K73.

The fix is in the following RPMS.
FC-3: 1.17.2-7
FC-2: 1.17.2-6
RHEL-3: 1.12-5.21.4

Comment 6 John Thacker 2006-04-22 04:45:07 UTC
Long been fixed.  Closing bug appropriately.


Note You need to log in before you can comment on or make changes to this bug.