Bug 133335 - Anaconda crashes during install
Anaconda crashes during install
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target 133260 FC4Target
  Show dependency treegraph
 
Reported: 2004-09-23 05:03 EDT by Emmanuel Seyman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-14 19:10:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Python traceback produced by anaconda crash (710 bytes, text/plain)
2004-09-23 05:09 EDT, Emmanuel Seyman
no flags Details

  None (edit)
Description Emmanuel Seyman 2004-09-23 05:03:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3)
Gecko/20040922

Description of problem:

Install of FC3t2 crashes after the root-password-setting page.

The installation is on an ext3 partition of a drive which has another
partition with a FC2 install. The only remarquable thing I did was
check the "do not install grub" option (since I use the FC2 grub to
double boot between the two systems). Firewall is also disabled (I
don't need it). Everything else is the default, I think.

After entering the root password in both text boxes and clicking on
"Next", anaconda crashes with a python traceback (see attached).

Version-Release number of selected component (if applicable):
anaconda-10.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 as described above
2. Enter root password in both text boxes
3. Click on the "Next" button
4. See program crash

Actual Results:  FC3t2 is not installed on the system.

Expected Results:  FC3t2 should be installed and testing should
continue. :-)

Additional info:
Comment 1 Emmanuel Seyman 2004-09-23 05:09:41 EDT
Created attachment 104170 [details]
Python traceback produced by anaconda crash
Comment 2 Jeremy Katz 2004-09-23 11:39:42 EDT
Is there a longer anacdump.txt?  There's some information missing from
this traceback that would be quite useful.

Also, is this reliably reproducible?

Was this using the DVD iso?
Comment 3 Emmanuel Seyman 2004-09-23 12:55:38 EDT
> Is there a longer anacdump.txt?

I'm afraid not. These are the only messages I get, both on the
graphical and text terminal.

> Also, is this reliably reproducible?

Every single time. I also tried selecting the Custom and Server
profiles which make no difference.

> Was this using the DVD iso?

The three CD isos are in a directory on the hard drive (yet another
partition). The kernel and initrd files have been copied to the /boot
directory on the FC2 system. I boot with grub and select the "Hard
Drive" install.
Comment 4 Jeremy Katz 2004-09-23 19:18:41 EDT
Can you verify the md5sums of your cds?  And 3 cds or 4?
Comment 5 Emmanuel Seyman 2004-09-23 20:13:54 EDT
The md5sums of all 4 CDs are ok (yes, it's 4 but you only need the
first 3 for the french default install).

Burning to CD allows me to complete the install, using the exact same
options as the "install from hard drive" option (whee!!!!).

So the bug is activated only if you install from hard drive ???
Comment 6 Jeremy Katz 2004-09-24 12:17:12 EDT
If you put the fourth cd there does it work?
Comment 7 Emmanuel Seyman 2004-09-25 04:40:31 EDT
All four isos have been in the directory since day one.
Comment 8 Emmanuel Seyman 2004-10-19 18:03:31 EDT
Reproduced with FC3t3.
Same error with only minor changes (build, line numbers).

Traceback (most recent call last):
File "/usr/src/build/465026-i386/install//usr/lib/anaconda/gui.py",
line 789 in nextClicked
        self.dispatch.gotoNext()
File
"/usr/src/build/465026-i386/install//usr/lib/anaconda/dispatch.py",
line 171 in gotoNext
        self.movestep
File
"/usr/src/build/465026-i386/install//usr/lib/anaconda/dispatch.py",
line 239 in moveStep
        rc = apply(func, self.bindArgs(args))
File
"/usr/src/build/465026-i386/install//usr/lib/anaconda/packages.py",
line 156 in readPackages
        hdrlist = methode.readHeaders()
File
"/usr/src/build/465026-i386/install//usr/lib/anaconda/harddrive.py",
line 155 in readHeaders
        if not self.discImages.has_key(h[1000002]);
TypeError: List objects are unhashable

Booting to the rescue CD and attempting a hard drive install fails too.
Again, burning the first 3 CD and installing from them is fine.

3 days before FC3t3 came out, I tried to install Red Hat Linux 9 for
some legacy testing.
That too failed with pratically the same error (ping me if you need
the exact lines).

FWIW, here's the layout of the drive:

Disque /dev/hda: 60.0 Go, 60011642880 octets
255 têtes, 63 secteurs/piste, 7296 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
 
Périphérique Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         650     5221093+  83  Linux
/dev/hda2             651        1300     5221125   83  Linux
/dev/hda3            1301        1431     1052257+  82  Linux swap
/dev/hda4            1432        7296    47110612+   f  W95 Ext'd (LBA)
/dev/hda5            1432        7296    47110581   83  Linux
Comment 9 Emmanuel Seyman 2004-11-14 19:10:15 EST
Installing FC3 on /dev/hda1 succeds.
Installing it on /dev/hda2 gets me past the "Calculating dependencies
on selected packages" dialog.
Resolving as WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.