Bug 133382 - background chooser doesn't know about installed backgrounds
background chooser doesn't know about installed backgrounds
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
: 129561 (view as bug list)
Depends On:
Blocks: FC3Target 131589
  Show dependency treegraph
 
Reported: 2004-09-23 13:00 EDT by Matthias Clasen
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 00:09:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
all backgrounds in desktop-backgrounds-basic (18.55 KB, text/plain)
2004-09-23 14:24 EDT, Matthias Clasen
no flags Details
all backgrounds in desktop-backgrounds-extra (65.69 KB, text/plain)
2004-09-23 14:25 EDT, Matthias Clasen
no flags Details

  None (edit)
Description Matthias Clasen 2004-09-23 13:00:04 EDT
I just tried to change the background on the fresh rawhide install,
and although the desktop-backgrounds-* packages are installed, 
gnome-background-properties doesn't offer any backgrounds.

I think we should

a) add xml files for at least some of the backgrounds to 
/usr/share/gnome-destop-properties

b) make sure the file chooser has a bookmark for /usr/share/backgrounds

I'm currently trying to find out a bit more about the xml format 
for a)...
Comment 1 Matthias Clasen 2004-09-23 14:21:48 EDT
Ok, so adding all the images in the desktop-background-* packages 
makes the dialog incredibly slow to startup, so we clearly have
to pick a handful (10 - 20) good backgrounds from the packages and 
remove the rest from the xml files I'm attaching shortly.
Comment 2 Matthias Clasen 2004-09-23 14:24:20 EDT
Created attachment 104206 [details]
all backgrounds in desktop-backgrounds-basic
Comment 3 Matthias Clasen 2004-09-23 14:25:11 EDT
Created attachment 104207 [details]
all backgrounds in desktop-backgrounds-extra
Comment 4 Matthias Clasen 2004-09-23 14:26:09 EDT
Additionally, we should add a preview to the file chooser, and make
sure it starts up in /usr/share/backgrounds.
Comment 5 Matthias Clasen 2004-09-23 15:08:25 EDT
I've asked Diana to come up with a short list of images to show initially.
Comment 6 Matthias Clasen 2004-09-24 10:31:10 EDT
I have a patch ready to add a simple preview to the file chooser.
Comment 7 Matthias Clasen 2004-09-24 10:34:28 EDT
And, for reference, the upstream bugs related to these issues are
http://bugzilla.gnome.org/show_bug.cgi?id=139714
and
http://bugzilla.gnome.org/show_bug.cgi?id=145069
Comment 8 Matthias Clasen 2004-09-24 13:37:39 EDT
Added the preview to the file chooser now, in control-center-2.8.0-5
Keeping this bug open to add the initial list of backgrounds.
Comment 9 Matthias Clasen 2004-09-27 11:29:44 EDT
desktop-backgrounds-basic-2.0-24 should has the prepopulated list of
backgrounds.
Comment 10 Matthias Clasen 2004-09-29 02:07:14 EDT
*** Bug 129561 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.