Bug 1333942 - SSUI : Total count of requests displayed in SSUI dashboard are wrong
Summary: SSUI : Total count of requests displayed in SSUI dashboard are wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.0
Assignee: Aparna Karve
QA Contact: Shveta
URL:
Whiteboard: ssui
: 1322937 1333120 (view as bug list)
Depends On:
Blocks: 1335222
TreeView+ depends on / blocked
 
Reported: 2016-05-06 18:05 UTC by Shveta
Modified: 2016-06-29 16:00 UTC (History)
8 users (show)

Fixed In Version: 5.6.0.8
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1335222 (view as bug list)
Environment:
Last Closed: 2016-06-29 16:00:14 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
total count of requests (64.48 KB, image/png)
2016-05-06 18:05 UTC, Shveta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Shveta 2016-05-06 18:05:07 UTC
Created attachment 1154720 [details]
total count of requests

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. All counts of requests are wrong on SSUI dashboard
2. As in attached screenshot the dashboard shows : Pending req = 13 , Approved requests = 13 and denied requests = 13 , Total requests are also 13 .
3. retired Service shows 10 , where as only 2 are retired

Actual results:


Expected results:


Additional info:
Build : 

5.6.0.5-beta2.4.20160503153816_1fb554f

Comment 3 Aparna Karve 2016-05-12 19:26:17 UTC
*** Bug 1333120 has been marked as a duplicate of this bug. ***

Comment 4 Aparna Karve 2016-05-12 19:36:38 UTC
*** Bug 1322937 has been marked as a duplicate of this bug. ***

Comment 6 CFME Bot 2016-05-18 17:59:08 UTC
New commit detected on ManageIQ/manageiq-ui-self_service/master:
https://github.com/ManageIQ/manageiq-ui-self_service/commit/68ba145668ede221c9839766e88c5b7503aeb445

commit 68ba145668ede221c9839766e88c5b7503aeb445
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Wed May 11 12:29:40 2016 -0700
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Thu May 12 12:37:01 2016 -0700

    Do not apply filters for Dashboard Total Services and Requests
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1333942

 client/app/states/dashboard/dashboard.state.js | 2 ++
 client/app/states/requests/list/list.state.js  | 9 ++++++---
 client/app/states/services/list/list.state.js  | 9 ++++++---
 3 files changed, 14 insertions(+), 6 deletions(-)

Comment 7 Shveta 2016-05-26 16:21:59 UTC
Fixed.
verified in 5.6.0.8-rc1.20160524155303_f2a5a50

Comment 9 errata-xmlrpc 2016-06-29 16:00:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.