Bug 133407 - kickstart (x86_64 rhel3) fails against satellite
kickstart (x86_64 rhel3) fails against satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
Max Spevack
:
Depends On:
Blocks: 119091 131093
  Show dependency treegraph
 
Reported: 2004-09-23 16:01 EDT by Max Spevack
Modified: 2007-07-31 10:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 15:39:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-09-23 16:01:51 EDT
Description of problem:
Using Satellite 3.4.0 and trying to kickstart an AMD x86_64 box, the
kickstart scheduling screen fails with the error "Could not find the
needed RHN provisioning packages given this system's current base
channel and desired target channel."

Steps taken:
1.  satellite-sync -c rhel-x86_64-as-3 -c rhn-tools-rhel-3-as-x86_64
2.  rhn_register to reg the system to the satellite
3.  Created the kickstart profile and tried to schedule the action.


Version-Release number of selected component (if applicable):
satellite-3.4.0

How reproducible:
Always

Steps to Reproduce:
1.  Log in to satellite on http://farm03.rhndev.redhat.com as
farm03/dog8code
2.  Follow the steps above.  The client system that we are trying to
kickstart is test01.x86_64.rhndev.redhat.com
3.
  
Actual results:
See error message above.

Expected results:
Successful kickstart of box.

Additional info:
Comment 1 Max Spevack 2004-09-24 13:41:32 EDT
Noticing the same error message when testing rhel2.1-U5 for i386
Comment 2 Max Spevack 2004-09-24 14:30:11 EDT
Just to clarify, the autokickstart packages *are* present on the
satellite machine.
Comment 3 Max Spevack 2004-09-28 14:00:35 EDT
This bug was a result of the channels not being synced properly.  It's
actually not a bug.
Comment 4 Clifford Perry 2004-09-28 14:52:07 EDT
Since I had a customer with this exact same issue - was this confirmed
to be fixed ? If so, just ask customer to re-run satellite-sync to
pull in missing data ?

Cliff. 
Comment 5 Max Spevack 2004-09-28 15:15:55 EDT
The "fix" was that the tools channels were not all synced properly. 
For example, I had the machine installed with 2.1WS, and I wanted to
do a kickstart to 2.1AS -- however, on the satellite machine from
which the kickstart was being setup, the 2.1WS channel had not been
properly synced, and it didn't have the autokickstart RPMs necessary
to properly setup the kickstart.

Syncing all the tools channels solved this problem.
Comment 7 Adam Stokes 2004-09-29 12:17:34 EDT
After doing the test here still seeing this error as of 11 am. Same
scenario please let me know if I need to provide anymore information.
Comment 8 Max Spevack 2004-09-29 12:42:31 EDT
What is the customer's scenario?  Have the synced all their channels
(including the tools channel)?  What version of satellite?  What kind
of kickstart?  etc.
Comment 12 Robin Norwood 2004-10-01 11:02:30 EDT
ok - not being able to kickstart to -u2 is a known issue - so long as
you can ks to -u3, that's the best we can do.

A fix for -u2 is in the works.
Comment 13 Max Spevack 2004-10-01 13:17:10 EDT
I can kickstart from that same satellite to rhel3-x86_64-as-3-u3

Note You need to log in before you can comment on or make changes to this bug.