Bug 133419 - 'Additional Language Support' GUI event handling error
'Additional Language Support' GUI event handling error
Status: CLOSED DUPLICATE of bug 133164
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 16:59 EDT by Terry Froy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Froy 2004-09-23 16:59:35 EDT
Description of problem:

The 'Additional Language Support' portion of Anaconda will crash if no
languages are ticked at any point.

The behaviour of Anaconda prior to the Fedora Core 3 test releases was
that at least one language must be ticked at any one time, if only one
language was ticked (i.e. English USA), the user must tick another
language (i.e. English UK) and then untick the default language (i.e.
English USA).

If only one language was ticked, Anaconda would *not* let you untick it.

This release of Anaconda (I have not verified if problem exists in
earlier Fedora Core 3 test releases) generates an immediate Python
traceback if the default language, English USA, is unticked *prior* to
selecting a second language.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora Core 3 Test 3 CD #1.
2. Proceed with installation as normal until you get to the
'Additional Language Support' portion of Anaconda.
3. Untick the 'English (USA)' language.
  
Actual results:

The traceback generated by Anaconda is below:

Traceback (most recent call last):
 File
"/usr/src/build/451389-i386/install//usr/lib/anaconda/iw/language_support_gui.py",
 line 66, in toggled_language
 self.rebuild_combo();
 File
"/usr/src/build/451389-i386/install//usr/lib/anaconda/iw/language_support_gui.py",
 line 84, in rebuild_combo
 self.defaultLang = self.deflang_values[curidx]
IndexError: list index out of range

Expected results:

Anaconda should either not allow the initial default language to be
unticked until at least one other language is ticked.

In simple terms, it should behave more like earlier versions of
Anaconda (see any version of Anaconda which ships with Red Hat Linux
8.0 or later).

Additional info:

I have temporarily worked around the problem by ticking the preferred
language before unticking English (USA), like so:

1:) English USA [X]
    English UK [X]     <--- Tick English UK first.

3:) English USA [ ]    <--- ... then untick English USA.
    English UK [X]
Comment 1 Terry Froy 2004-09-23 17:13:16 EDT
It looks like this may be related to Bug 133164.
Comment 2 Jeremy Katz 2004-09-24 12:07:16 EDT

*** This bug has been marked as a duplicate of 133164 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.