Bug 133164 - Installer crash when unchecking French (France) language
Installer crash when unchecking French (France) language
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 133419 (view as bug list)
Depends On:
Blocks: 133260
  Show dependency treegraph
 
Reported: 2004-09-21 20:16 EDT by Thierry moisan
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the backtrace (55.21 KB, text/plain)
2004-09-22 17:32 EDT, Thierry moisan
no flags Details

  None (edit)
Description Thierry moisan 2004-09-21 20:16:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040815 Firefox/0.9.1+

Description of problem:
Ok, I downloaded fc3test2 and all the md5sum were fine. Burned the cd,
started the installtion. I chosse french language, french canadian
keyboard, no firewall and when it comes to choose the languages to
install on fedora, I try click to uncheck "french (france)" and then
it crash. Don't know if the keyboard or firewall or anything I've done
before is linked to this but I tried a few times the same way and it
was reproducible.

Version-Release number of selected component (if applicable):
anaconda of fc3test2

How reproducible:
Always

Steps to Reproduce:
1.french
2.french canadian keyboard
3.no firewall
4.uncheck "french (France)"
    

Actual Results:  Crash

Expected Results:  No crash and uncheck of the "french (France)" checkbox

Additional info:

I had a backtrace saved on a floppy, but fedora doesn't said this :
"mount: I could not determine the filesystem type, and none was
specified" so I can't send it. If you really need it e-mail me at
thierryn@videotron.ca . Maybe I'll come back and send it here later also.
Comment 1 Jeremy Katz 2004-09-21 21:51:05 EDT
It should be a DOS floppy... without the backtrace, it's very
difficult for me to discern what happened.
Comment 2 Thierry moisan 2004-09-22 17:32:57 EDT
Created attachment 104145 [details]
the backtrace

the backtrace of the bug
Comment 3 Thierry moisan 2004-09-22 17:34:43 EDT
sent the backtrace, hope this help
Comment 4 Jeremy Katz 2004-09-24 12:07:31 EDT
*** Bug 133419 has been marked as a duplicate of this bug. ***
Comment 5 Thierry moisan 2004-09-24 17:57:07 EDT
I retried the installation but this time, I choosed to have the
firewall on. At my surprise, the installation went fine, and I'm now
on fc3test2.
So, by simple deduction, I think putting firewall on or off is
important in this bug.
Comment 6 Terry Froy 2004-09-25 04:18:58 EDT
Hello,

I duplicated this bug report as 133419.

This bug triggered for me whether I had configured a firewall via 
Anaconda or not.

Thierry:

Can you please read Bug 133419 and confirm if your issue is related 
to the order in which you unselected France (France) and selected 
your preferred language ?

More importantly, can you try selecting your preferred language first 
before unselecting France (France) ?

From my analysis of the code referred to in my own traceback, I 
cannot see where the firewall configuration could cause this bug.

I believe Bug 133419 explains it in more detail.

Regards,
Terry
Comment 7 Thierry moisan 2004-09-25 08:26:11 EDT
Ok, I confirm that the bug only happen when I unselect French (France)
and that there is no other language selected. When I select my
preferred language first before unselecting French (France) I have no
bug at all.
I retried some few times the installation to see if the firewall is
really linked to this and it's not. My error sorry. My issue is the
same  as the Bug 133419.

Thierry
Comment 8 Jeremy Katz 2004-09-27 16:09:39 EDT
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.