Bug 1334479 - tuned realtime profiles need rcu_nocbs
Summary: tuned realtime profiles need rcu_nocbs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
Jiri Herrmann
URL:
Whiteboard:
: 1356717 (view as bug list)
Depends On:
Blocks: kvm-rt-tuned 1273048 1367502
TreeView+ depends on / blocked
 
Reported: 2016-05-09 18:10 UTC by Andrew Theurer
Modified: 2016-11-04 07:27 UTC (History)
13 users (show)

Fixed In Version: tuned-2.7.0-1.el7
Doc Type: Release Note
Doc Text:
*rcu-nocbs* no longer missing from kernel boot parameters Previously, the *rcu_nocbs* kernel parameter was not set in the `realtime-virtual-host` and `realtime-virtual-guest` tuned profiles. With this update, *rcu-nocbs* is set as expected.
Clone Of:
: 1367502 (view as bug list)
Environment:
Last Closed: 2016-11-04 07:27:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description Andrew Theurer 2016-05-09 18:10:56 UTC
Description of problem:

tuned realtime-virtual-{host|guest] have rcu_nocbs missing from boot/kernel parameters

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Activate either realtime-virtual-host or realtime-virtual-guest profiles
2. Reboot
3. cat /proc/cmdline

Actual results:
rcu_nocbs=$isolated_cores is missing

Expected results:
rcu_nocbs=$isolated_cores is included

Additional info:
/usr/lib/tuned/realtime/tuned.conf needs to be updated to include:

cmdline=isolcpus=${isolated_cores} nohz_full=${isolated_cores} rcu_nocbs=${isolated_cores} intel_pstate=disable nosoftlockup

Comment 4 Jaroslav Škarvada 2016-06-15 14:04:02 UTC
Upstream commit adding the fix:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=2d89b31cf9c19c6526a4a6136fdcc037a49b4256

Comment 6 Jaroslav Škarvada 2016-07-15 14:39:35 UTC
*** Bug 1356717 has been marked as a duplicate of this bug. ***

Comment 7 Luiz Capitulino 2016-07-15 19:33:06 UTC
As reported in bug 1356717, this issue is a blocker as you can't start VMs with the RT kernel starting with kernel-rt-3.10.0-439.rt56.327.el7.

Comment 9 Luiz Capitulino 2016-07-25 18:22:15 UTC
We need this for 7.2.z too.

Comment 12 Tereza Cerna 2016-08-23 08:49:06 UTC
=========================================
Verified in:
    tuned-2.7.1-2.el7.noarch
    tuned-profiles-nfv-2.7.1-2.el7.noarch
PASS
=========================================

# cat /usr/lib/tuned/realtime-virtual-host/tuned.conf | grep cmdline
cmdline=isolcpus=${isolated_cores} nohz=on nohz_full=${isolated_cores} rcu_nocbs=${isolated_cores} intel_pstate=disable nosoftlockup
# cat /etc/tuned/realtime-virtual-host-variables.conf
isolated_cores=1
# tuned-adm profile realtime-virtual-host
# reboot
# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-493.el7.x86_64 root=/dev/mapper/rhel_dell--pe--fm120--2c-root ro crashkernel=auto rd.lvm.lv=rhel_dell-pe-fm120-2c/root rd.lvm.lv=rhel_dell-pe-fm120-2c/swap console=ttyS0,115200n81 isolcpus=1 nohz=on nohz_full=1 rcu_nocbs=1 intel_pstate=disable nosoftlockup

The same behavior is also for realtime-virtual-guest.

=========================================
Reproduced in:
    tuned-2.5.1-7.el7.noarch
    tuned-profiles-nfv-2.5.1-7.el7.noarch
FAIL
=========================================

# cat /usr/lib/tuned/realtime-virtual-host/tuned.conf | grep cmdline
cmdline=isolcpus=${isolated_cores} nohz=on nohz_full=${isolated_cores} intel_pstate=disable nosoftlockup
# cat /etc/tuned/realtime-virtual-host-variables.conf
isolated_cores=1
# tuned-adm profile realtime-virtual-host
# reboot
# cat /proc/cmdline 
# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-493.el7.x86_64 root=/dev/mapper/rhel_dell--pe--fm120--2c-root ro crashkernel=auto rd.lvm.lv=rhel_dell-pe-fm120-2c/root rd.lvm.lv=rhel_dell-pe-fm120-2c/swap console=ttyS0,115200n81 isolcpus=1 nohz=on nohz_full=1 intel_pstate=disable nosoftlockup

Comment 14 errata-xmlrpc 2016-11-04 07:27:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.