Bug 1356717 - tuned-profiles-nfv: add rcu_nocbs to kernel cmd-line
Summary: tuned-profiles-nfv: add rcu_nocbs to kernel cmd-line
Keywords:
Status: CLOSED DUPLICATE of bug 1334479
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: kvm-rt-tuned
TreeView+ depends on / blocked
 
Reported: 2016-07-14 20:42 UTC by Luiz Capitulino
Modified: 2016-07-15 21:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 14:39:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Luiz Capitulino 2016-07-14 20:42:51 UTC
Description of problem:

Starting with kernel-rt-3.10.0-439.rt56.327.el7, we now have CONFIG_RCU_NOCB_CPU_NONE=y (instead of CONFIG_RCU_NOCB_CPU_ALL=y). This means that we're required to specify no-CBs CPUs with rcu_nocbs=. Otherwise we'll run into spikes.

The [bootloader] section in both guest and host tuned.conf must have the following option:

rcu_nocbs=${isolated_cores}


Version-Release number of selected component (if applicable): tuned-2.5.1-7.el7.noarch

Comment 1 Luiz Capitulino 2016-07-14 20:46:37 UTC
Two additional notes:

- I'm not sure if the realtime profile should get this option too (probably yes)

- There seems to be a bug with CONFIG_RCU_NOCB_CPU_NONE=y where processes get stuck in D state during system boot. This issue is workarounded by rcu_nocbs=

Comment 2 Jaroslav Škarvada 2016-07-15 14:39:35 UTC
I guess this is dupe of bug 1334479. If not, please reopen.

*** This bug has been marked as a duplicate of bug 1334479 ***


Note You need to log in before you can comment on or make changes to this bug.