Bug 1334588 - Containers are failing with a system error on Atomic image
Summary: Containers are failing with a system error on Atomic image
Status: CLOSED DUPLICATE of bug 1328961
Alias: None
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
(Show other bugs)
Version: 24
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-10 06:38 UTC by kushaldas@gmail.com
Modified: 2016-05-11 18:29 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-11 18:29:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kushaldas@gmail.com 2016-05-10 06:38:23 UTC
$ rpm -q docker
docker-1.10.3-7.gita41254f.fc24.x86_64

We are trying to start a container on the Fedora 24 Atomic image

$ sudo docker run --rm -i -t fedora /bin/bash
docker: Error response from daemon: Cannot start container 6857baf9c5438208d89488f0383b5a2ac699e8fd7e8df8563652bab4dd3c8307: [9] System error: exit status 1.

Same with atomic command

$ sudo atomic run busybox
/usr/bin/docker create -t -i --name busybox busybox sh

[fedora@kushal-testday-atomic ~]$ echo $?
1


Expected result:

We are supposed to get the container starting up.

Actual result:

We are getting a cryptic message saying System error.

Comment 1 kushaldas@gmail.com 2016-05-10 07:11:11 UTC
As a side note on a Cloud Base image, installing the latest docker package works.

$ rpm -q docker
docker-1.10.3-9.git667d6d1.fc24.x86_64

Comment 2 Suraj Narwade 2016-05-10 13:40:03 UTC
I am trying to start Container, but it throwing error:
$ sudo docker run -i -t busybox /bin/bash
docker: Error response from daemon: Cannot start container d8d083c900addd3c18cbbd9076304511e154fdd9ef95d121939eeaf856179c05: [9] System error: exit status 1.

Comment 3 Daniel Walsh 2016-05-10 13:41:10 UTC
Are you running docker-1.10.3-9.git667d6d1.fc24.x86_64

Comment 4 Dusty Mabe 2016-05-11 15:46:54 UTC

Dan, I don't think so. They were running docker-1.10.3-7.gita41254f.fc24.x86_64 which is the latest in stable.

I just downloaded the latest atomic Nightly [1] and this is what I see when trying to run a container: 


XFS (dm-4): Unmounting Filesystem  
time="2016-05-11T14:51:32.226340399Z" level=error msg="error locating sandbox id 6f7d39cfe1b4441d8878381e5ac0b69a2d2a4adf306ee69848ac6f9ec9e1085c: sandbox 6f7d39cfe1b4441d8878381e5ac0b69a2d2a4adf306ee69848ac6f9ec9e1085c not found"
time="2016-05-11T14:51:32.226501768Z" level=warning msg="failed to cleanup ipc mounts:\nfailed to umount /var/lib/docker/containers/1bb05b671fddbd41e5a2be49bb8bed538fbab03544242e3c2411a322b72de41d/shm: invalid argument"
time="2016-05-11T14:51:32.226548821Z" level=error msg="Error unmounting container 1bb05b671fddbd41e5a2be49bb8bed538fbab03544242e3c2411a322b72de41d: not mounted"
time="2016-05-11T14:51:32.226741428Z" level=error msg="Handler for POST /v1.22/containers/1bb05b671fddbd41e5a2be49bb8bed538fbab03544242e3c2411a322b72de41d/start returned error: Cannot start container 1bb05b671fddbd41e5a2be49bb8bed538fbab03544242e3c2411a322b72de41d: [9] System error: exit status 1"
<info>  [1462978295.7974] device (docker0): link disconnected (calling deferred action)

If we want docker-1.10.3-9 then we'll have to test it and add karma


[1] - https://kojipkgs.fedoraproject.org//work/tasks/7646/14007646/Fedora-Atomic-24-20160511.n.0.x86_64.qcow2

Comment 5 kushaldas@gmail.com 2016-05-11 15:58:34 UTC
(In reply to Daniel Walsh from comment #3)
> Are you running docker-1.10.3-9.git667d6d1.fc24.x86_64

docker-1.10.3-9.git667d6d1.fc24.x86_64 works on Fedora Cloud base image, but the atomic image does not have it yet.

Comment 6 Dusty Mabe 2016-05-11 16:55:16 UTC
So I tried to test the new docker-1.10.3-9.git667d6d1.fc24.x86_64 on atomic manually because there is no updates-testing ostree (see https://fedorahosted.org/rel-eng/ticket/6408).

The steps I used are:

```
# run latest Atomic nightly from https://kojipkgs.fedoraproject.org//work/tasks/7646/14007646/Fedora-Atomic-24-20160511.n.0.x86_64.qcow2

setenforce 0 #BZ1330318

ostree admin unlock --hotfix

curl -O https://kojipkgs.fedoraproject.org//packages/docker/1.10.3/9.git667d6d1.fc24/x86_64/docker-1.10.3-9.git667d6d1.fc24.x86_64.rpm 
curl -O https://kojipkgs.fedoraproject.org//packages/docker/1.10.3/9.git667d6d1.fc24/x86_64/docker-selinux-1.10.3-9.git667d6d1.fc24.x86_64.rpm 
curl -O https://kojipkgs.fedoraproject.org//packages/selinux-policy/3.13.1/185.fc24/noarch/selinux-policy-3.13.1-185.fc24.noarch.rpm 
curl -O https://kojipkgs.fedoraproject.org//packages/selinux-policy/3.13.1/185.fc24/noarch/selinux-policy-targeted-3.13.1-185.fc24.noarch.rpm 


systemctl stop docker
rm -rf /var/lib/docker/*
lvremove atomicos/docker-pool

rpm -Uvh ./*rpm
reboot
```

Once I have the new docker installed I still can't start a container. This is a BIG deal for F24 Atomic.

Comment 7 Colin Walters 2016-05-11 18:29:40 UTC

*** This bug has been marked as a duplicate of bug 1328961 ***


Note You need to log in before you can comment on or make changes to this bug.