This service will be undergoing disruptive maintenance at 7:00PM UTC, 2020-01-18. It is expected to last approximately one hour.
Bug 133472 - redhat-config-printer crashes on startup
Summary: redhat-config-printer crashes on startup
Keywords:
Status: CLOSED DUPLICATE of bug 131563
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-24 09:39 UTC by Marc Giger
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marc Giger 2004-09-24 09:39:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
After updating the system I cannot configure the printers...:

# redhat-config-printer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 199, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 194, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.19-1

How reproducible:
Always

Steps to Reproduce:
1.start redhat-config-printer
2.
3.
    

Actual Results:  crash

Expected Results:  printer config dialog

Additional info:

Comment 1 Tim Waugh 2004-09-24 09:43:18 UTC

*** This bug has been marked as a duplicate of 131563 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:05:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.