This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 133487 - openoffice-kde causes segfault
openoffice-kde causes segfault
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 138961 (view as bug list)
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-24 09:06 EDT by Sammy
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 12:14:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bugbuddy output for crash (15.77 KB, text/plain)
2004-09-24 14:57 EDT, Sammy
no flags Details

  None (edit)
Description Sammy 2004-09-24 09:06:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
I just updated to version 1.1.2-5 from rawhide and starting every application
was segfaulting. When I removed the -kde package and left others than
it started to work fine. I am using KDE and at today's rawhide level.

Is the kde component compiled with kde-3.3 and qt-3.3? If it was compiled
on an eariler system for gcc reasons than this may be the problem.

Otherwise my problem of calc crashing when saving a file seems to have
been fixed.

Version-Release number of selected component (if applicable):
1.1.2-5

How reproducible:
Always

Steps to Reproduce:
1.update to version 1.1.2-5 including the kde package
2.under kde try to start any of the oo components
3.
    

Additional info:
Comment 1 Dan Williams 2004-09-24 11:46:24 EDT
Does the Bug Buddy dialog come up?  if so, can you "save" the
backtrace/segfault information that it gives you (there's a "debugging
details" button there that shows it) and attach it or paste it in here?
Comment 2 Sammy 2004-09-24 14:57:19 EDT
Created attachment 104283 [details]
bugbuddy output for crash
Comment 3 Sammy 2004-09-27 09:49:42 EDT
OK...tracked this down to using the baghira style under kde. This is a very 
popular theme (old liquid). When I change to another theme than the 
segfaults do not happen. If you think this is not oo problem please close. 
Comment 4 Isam Bayazidi 2004-09-28 03:11:02 EDT
I am using 1.1.2-6, and I get a crash and a sigfault with:
/usr/lib/ooo-1.1/program/kdefilepicker
OOo does not crash, but when I attempt to open a file, it crashes as
it calls the kdefilepicker
Comment 5 Isam Bayazidi 2004-10-10 04:18:53 EDT
Same problem still exist with 1.1.2-7 .. and I grabing 1.1.2-9 now,
and testing .. BTW, I do not use teh RPMs, but get the SRPM, and build it.
Comment 6 Isam Bayazidi 2004-10-11 02:27:51 EDT
Yesterday I build 1.1.2-9 from it's sources, and the same problem is
happening .. I think I spotted the reason.. when it builds the
kdefilepicker, it does not use the -lqt-mt flag, thus, it complains
about missing lib:
/usr/bin/ld: warning: libqt-mt.so.3, needed by /usr/lib/libkdeui.so,
not found (try using -rpath or -rpath-link)

And after it I get :
../unxlngi4.pro/slo/kdecommandthread.o(.text+0x86): In function
`CommandEvent::CommandEvent(QString const&, QStringList*)':
/usr/lib/qt-3.3/include/qstring.h:848: undefined reference to
`operator!=(QString const&, char const*)'
../unxlngi4.pro/slo/kdecommandthread.o(.text+0xbc): In function
`CommandEvent::CommandEvent(QString const&, QStringList*)':
/usr/lib/qt-3.3/include/qvaluelist.h:308: undefined reference to
`QEvent::~QEvent()'

and thens of those related to qt-mt .. Now I have the QT libs in
/usr/lib/qt-3.3/lib.. Is there something wrong in my build environment
? if so what is ? if not, why not add "-lqt-mt" to the gcc flags when
building the kdefilepicker
Comment 7 Caolan McNamara 2004-12-20 09:56:44 EST
How about now with 1.1.2-11.5.fc3, running oowriter and loading/saving
with an uptodate fc3 and updates shows no crashes/hangs with the file
dialog. Though I haven't tried with the non-standard baghira theme yet
Comment 8 Caolan McNamara 2004-12-21 03:58:34 EST
*** Bug 138961 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2004-12-21 04:37:14 EST
Given an uptodate FC3 I see only the hang/crash with the
not-shipped-with-FC baghira (0.6) theme with the file dialog, and then
only if you double click on a filename in it, single click and using
"Ok" works. (An alternative workaround is to use
tools->options->OpenOffice.org->general->Open/Save dialogs and check
use openoffice.org dialogs). 

Version 0.6 of baghira makes some mention of modifications for
OpenOffice.org. If this is only broken for baghira users in a
contemporary uptodate FC3/devel I reckon the burden is on baghira :-)
Comment 10 Caolan McNamara 2005-01-27 12:14:59 EST
Seeing as this can only be reproduced (AFAICS) with baghira which is
not part of FC3 I'm going to close this.

Note You need to log in before you can comment on or make changes to this bug.