Bug 133497 - folder created with programs disappear
folder created with programs disappear
Status: CLOSED DUPLICATE of bug 133665
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 10:13 EDT by Thierry moisan
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry moisan 2004-09-24 10:13:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
When I create a folder when I'm about to save a file (save as, create
a folder) on the Desktop, this folder disappear of the nautilus view
(go to the place the folder is suppose to be and it's not there). But
if you go see for the file by the terminal (cd Desktop && ls) the
folder is there. 

Version-Release number of selected component (if applicable):
nautilus-2.7.92-3

How reproducible:
Always

Steps to Reproduce:
1. Open a program (gedit or fileroller for me)
2. Save as (gedit) or extract (fileroller) 
3. Create a folder (gedit) or extract the files (fileroller) on the
desktop
4. Go see for the folder with nautilus 
    

Actual Results:  The folder or the files is(are) not there.

Expected Results:  That the folder or the files is(are) on the Desktop.

Additional info:

This only happens on the Desktop.
Comment 1 Thierry moisan 2004-09-24 18:22:36 EDT
When I rebooted, the folders created where on the desktop but I couldn't 
delet them by dropping them in the trash. When I put them in the trash
they were both in the trash and the desktop. When I checked the
Desktop by the terminal, the folder where still on the Desktop even
after I deleted them with the "rm" command. 
Comment 2 Alexander Larsson 2004-09-27 12:09:11 EDT
Sounds like file change notification isn't working.
Can you update to the latest version of gamin, log out and try again?
Comment 3 Thierry moisan 2004-09-27 19:28:23 EDT
I did updated gamin, loged out and no change.
Comment 4 Daniel Veillard 2004-09-27 19:35:48 EDT
I do not understand step 3 and 4 ... How do you
 "Create a folder on the desktop"
or
 "extract the files on the desktop" ?
Then how do you 
  "Go see for the folder with nautilus" ?
Do you mean launching a new nautilus, double clicking on an icon
on the desktop, what else ? Be extremely precise please !

If you're not precise enough that we can't reproduce this there
is little chance that the bug will be fixed quickly.

Daniel
Comment 5 Thierry moisan 2004-09-28 16:04:46 EDT
Ok, for "Create a folder on the desktop" step, I mean of opening
gedit, chossing to save the file, going to the desktop (with the save
file window) and to create a new folder on the Desktop. 
For "extract the files on the desktop" I mean to open any .tar.gz or
.zip file with fileroller and to simply extract the files on the Desktop.
Theses are only example of how to reproduce this bug, but there is a
lot more of way that are all similar for the thing that you save or
create something on the Desktop by a program.

When I say "Go see for the folder with nautilus" I mean to only close
all the windows of programs and go look at the Desktop. Like if you
were just starting the computer and that no program is running.

One last thing: what I was saying about putting files of the Desktop
in trash is no more a problem. I can put files in trash from Desktop
without any problem. Maybe because of the update of gamin, maybe not,
I don't know.
Thanks for helping
Thierry
Comment 6 John MacLean 2004-10-01 23:07:46 EDT
I can confirm the issue of items saved to the ~/Desktop folder not
appearing on the Desktop.

Using gedit I saved a file to ~/Desktop. File does not appear on
Desktop, nor does it appear if viewing this folder with 'File
Browser'. File does exist in 'ls ~/Desktop' output.

Selecting the Reload button in the file browser causes the new file to
appear in the Desktop and in the browser window.

Same for directories created using the gnome save as... dialog.

$ rpm -q gamin
gamin-0.0.12-1
$ ps ux | grep [g]am_server
john      9848  0.0  0.1  2856 1440 ?        S    22:05   0:00
/usr/libexec/gam_server
Comment 7 Daniel Veillard 2004-10-02 16:40:59 EDT
I think I know the source of the problem now, this is 
a duplicate of 133665, I should have a fix over the week-end
hopefully,

Daniel
Comment 8 Daniel Veillard 2004-10-02 16:41:20 EDT

*** This bug has been marked as a duplicate of 133665 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:05:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.