Bug 133665 - Desktop does not refresh when new file is created
Desktop does not refresh when new file is created
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
: 133497 133656 147603 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-25 18:20 EDT by Andrew
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 14:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew 2004-09-25 18:20:00 EDT
Description of problem:
If a file is saved on the Desktop (~/Desktop), the file does not
appear on the desktop immediately.

Version-Release number of selected component (if applicable):
gnome-desktop-2.7.92-1, probably gnome 2.8.x as well

How reproducible:
Every time.

Steps to Reproduce:
1. Go to the web
2. Download a file, select save and choose Desktop in the GNOME file
selector and Save.
3.
  
Actual results:
Desktop is blank, file does not show up.
  
Expected results:
Any new files saved to the Desktop should appear immediately.

Additional info:

If one opens the home directory, then selects Desktop and then does
View->Reload, the file then appears.
Comment 1 Mark McLoughlin 2004-09-27 03:27:24 EDT
*** Bug 133656 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2004-09-27 04:06:49 EDT
What version of gamin do you have installed ?
Comment 3 Andrew 2004-09-28 09:09:04 EDT
gamin-0.0.10-1, but running up2date as I type.
Comment 4 Andrew 2004-09-28 09:10:55 EDT
Also, I have a similar problem with the new "usbdisk" icon not
appearing on the desktop when my usb key is inserted.  Mount confirms
that it does mount /dev/sda1 to /media/usbdisk.  Just so you know...
Comment 5 sangu 2004-10-01 14:16:41 EDT
My situation.

to shell 1.
1. open with  "A folder" with gthumb and nautilus.

/usr/libexec/gam_server --notimeout test
Could not open /dev/inotify
Initialized Poll
dnotify initialized
Using DNotify as backend
Ready listening to socket /tmp/fam-sangu-test : 5
gam_incoming_conn_read called
accepted incoming connection: 6
Created connection 6
gam_client_conn_read called
read credentials byte
Credentials: s_uid 501, c_uid 501, c_gid 501, c_pid 10600
Created listener for 10600
Wrote 1 bytes to socket 6
gam_client_conn_read called
read 33 bytes from client
Request: from 10600, seq 1, type 2
Created subscription for /home/sangu/WORK/test/A
gam_dnotify_add_subscription
Poll: added subscription
gam_dnotify_consume_subscriptions()
gam_dnotify_add_subscription: done
gam_dnotify_consume_subscriptions_real()
1 new subscriptions.
activated DNotify for /home/sangu/WORK/test/A
Looking for existing files in: /home/sangu/WORK/test/A...
Poll: poll_file for /home/sangu/WORK/test/A called
Poll: poll_file : new
Poll: scanning directory /home/sangu/WORK/test/A
Event to 10600 : /home/sangu/WORK/test/A Exists
Wrote 33 bytes to socket 6
Event to 10600 : /home/sangu/WORK/test/A None
Wrote 33 bytes to socket 6
Done scanning /home/sangu/WORK/test/A

2. Open nautilus "B folder".
some image files are in B folder.

3. Copy  A Image file to "A folder" from "B folder".

Done scanning /home/sangu/WORK/test/A
signal handler done
gam_dnotify_pipe_handler()
handling signal
Poll: scanning /home/sangu/WORK/test/A: subs 0
Poll: poll_file for /home/sangu/WORK/test/A called
 at 1096654252 delta 7 : 0
Poll: scanning directory /home/sangu/WORK/test/A
Poll: poll_file for /home/sangu/WORK/test/A/.vfs-write.tmp called
Poll: poll_file : new
Poll: emit events for /home/sangu/WORK/test/A/.vfs-write.tmp
Event to 10649 : .vfs-write.tmp Created
Wrote 24 bytes to socket 6
Poll: scanning /home/sangu/WORK/test/A done
gam_dnotify_pipe_handler() done
signal handler done
gam_dnotify_pipe_handler()
handling signal
Poll: scanning /home/sangu/WORK/test/A: subs 0
Poll: poll_file for /home/sangu/WORK/test/A called
 at 1096654252 delta 0 : 0
Poll: scanning directory /home/sangu/WORK/test/A
Poll: poll_file for /home/sangu/WORK/test/A/.vfs-write.tmp called
 at 1096654252 delta 0 : 0
Poll: emit events for /home/sangu/WORK/test/A/.vfs-write.tmp
Event to 10649 : .vfs-write.tmp Deleted
Wrote 24 bytes to socket 6
Poll: scanning /home/sangu/WORK/test/A done
gam_dnotify_pipe_handler() done
signal handler done
gam_dnotify_pipe_handler()
handling signal
Poll: scanning /home/sangu/WORK/test/A: subs 0
Poll: poll_file for /home/sangu/WORK/test/A called
 at 1096654252 delta 0 : 1
Poll: scanning directory /home/sangu/WORK/test/A
Poll: poll_file for /home/sangu/WORK/test/A/img.jpg called
Poll: poll_file : new
Poll: emit events for /home/sangu/WORK/test/A/img.jpg
Event to 10649 : img.jpg Created
Wrote 17 bytes to socket 6
Poll: poll_file for /home/sangu/WORK/test/A/.vfs-write.tmp called
 at 1096654252 delta 0 : 0
Poll: scanning /home/sangu/WORK/test/A done
gam_dnotify_pipe_handler() done

4. The image file don't appear before refresh gthumb.

refresh in gthumb.

gam_client_conn_read called
read 10 bytes from client
Request: from 10649, seq 1, type 3
Cancelling subscription for (1)
gam_dnotify_remove_subscription
Poll: removed subscription
gam_dnotify_consume_subscriptions()
gam_dnotify_remove_subscription: done
gam_dnotify_consume_subscriptions_real()
Tree has 7 nodes
Removing: /home/sangu/WORK/test/A
deactivated DNotify for /home/sangu/WORK/test/A
gam_dnotify_file_handler /home/sangu/WORK/test/A/img.jpg : 0
gam_dnotify_file_handler /home/sangu/WORK/test/A/.vfs-write.tmp : 0
Freeing subscription for /home/sangu/WORK/test/A
Tree has 0 nodes
gam_client_conn_read called
read 33 bytes from client
Request: from 10649, seq 2, type 2
Created subscription for /home/sangu/WORK/test/A
gam_dnotify_add_subscription
Poll: added subscription
gam_dnotify_consume_subscriptions()
gam_dnotify_add_subscription: done
gam_dnotify_consume_subscriptions_real()
1 new subscriptions.
activated DNotify for /home/sangu/WORK/test/A
Looking for existing files in: /home/sangu/WORK/test/A...
Poll: poll_file for /home/sangu/WORK/test/A called
Poll: poll_file : new
Poll: scanning directory /home/sangu/WORK/test/A
Event to 10649 : /home/sangu/WORK/test/A Exists
Wrote 33 bytes to socket 6
Poll: poll_file for /home/sangu/WORK/test/A/img.jpg called
Poll: poll_file : new
Poll: emit events for /home/sangu/WORK/test/A/img.jpg
Event to 10649 : img.jpg Exists
Wrote 17 bytes to socket 6
Event to 10649 : /home/sangu/WORK/test/A None
Wrote 33 bytes to socket 6
Done scanning /home/sangu/WORK/test/A

6. Copy to B From A.

signal handler done
gam_dnotify_pipe_handler()
handling signal
Poll: scanning /home/sangu/WORK/test/A: subs 0
Poll: poll_file for /home/sangu/WORK/test/A called
 at 1096654732 delta 326 : 0
Poll: scanning directory /home/sangu/WORK/test/A
Poll: poll_file for /home/sangu/WORK/test/A/img.jpg called
 at 1096654732 delta 326 : 0
Poll: emit events for /home/sangu/WORK/test/A/img.jpg
Event to 10649 : img.jpg Deleted
Wrote 17 bytes to socket 6
Poll: scanning /home/sangu/WORK/test/A done
gam_dnotify_pipe_handler() done

------------
to shell2

$ gthumb
Client need auth 16
read credentials byte
Credentials: s_uid 501, c_uid 501, c_gid 501, c_pid 10648
read 66 bytes from server
read 24 bytes from server
read 24 bytes from server
read 17 bytes from server
read 83 bytes from server
read 17 bytes from server

(gthumb:10649): Gtk-CRITICAL **: file gtktreeview.c: line 9866
(gtk_tree_view_scroll_to_cell): assertion `tree_view->priv->tree !=
NULL' failed

Comment 6 Daniel Veillard 2004-10-01 18:09:49 EDT
> Event to 10649 : img.jpg Created
> ...
> 4. The image file don't appear before refresh gthumb.

  Well gam_server did its job. it did send the Created event with
the right filename to the application !
  This should be available as a FAMEvent to the application as a
newly created file. 

  Can you run gthumb with GAM_DEBUG defined and see if the gamin
library events are reveived. They should be received, the socket
should be monitored as part of the application event loop, if it
doesn't then there is a bug above gamin, possibly in the gnome-vfs
layer.

Daniel
Comment 7 sangu 2004-10-01 21:25:30 EDT
Daniel : Isn't this gthumb's run with GAM_DEBUG?
to shell 2
$ export GAM_DEBUG=
$ export GAM_CLIENT_ID=test
$ gthumb
Client need auth 16
read credentials byte
Credentials: s_uid 501, c_uid 501, c_gid 501, c_pid 10648
read 66 bytes from server
read 24 bytes from server
read 24 bytes from server
read 17 bytes from server
read 83 bytes from server
read 17 bytes from server

(gthumb:10649): Gtk-CRITICAL **: file gtktreeview.c: line 9866
(gtk_tree_view_scroll_to_cell): assertion `tree_view->priv->tree !=
NULL' failed


Comment 8 Daniel Veillard 2004-10-02 16:39:02 EDT
I have reproduced the problem. I know why it occurs now, so I 
expect top be able to get a fix over the week-end. I have enough
debug informations now ;-)

Daniel
Comment 9 Daniel Veillard 2004-10-02 16:41:38 EDT
*** Bug 133497 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Veillard 2004-10-03 14:51:41 EDT
I pushed gamin-0.0.14 to rawhide, it should show up this week,
you can grab it from 
  http://www.gnome.org/~veillard/gamin/downloads.html

I tried and for me it fixes the issue.

Daniel
Comment 11 sangu 2004-10-03 22:08:34 EDT
Daniel : This problem still does happen in my linux box.

gamin-0.0.14-1, gnome-vfs2-2.8.1-5, nautilus-2.8.0-1

http://hellocity.net/~sangu/files/gamin/gamin-0.0.14-1.png
http://hellocity.net/~sangu/files/gamin/gamin-0.0.14-2.png
Comment 12 Daniel Veillard 2004-10-04 09:53:04 EDT
I was able to reproduce the bug described in the initial comment
when the bug was oppened. I fixed that bug. 
I see no relationship between the original bug and the 2
screenshot you provided in comment #11, I have no idea what
they are supposed to illustrate.
If you have a separate problem, open a bug and report how to reproduce
it. For me the bug reported is fixed in 0.0.14.

Daniel
Comment 13 sangu 2004-10-04 10:13:27 EDT

Like screenshot, image file is seen in A folder of nautilus, but
gthumb isn't.

So reflesh (ctrl+r) in gthumb or nautilus, then image file appear in
gthumb.

Thumbnail image isn't sometimes updated like gamin-0.0.14-2.png.


Comment 14 Alexander Larsson 2005-02-10 03:31:20 EST
*** Bug 147603 has been marked as a duplicate of this bug. ***
Comment 15 Juan C Nuno 2005-02-10 03:38:11 EST
The bug I filed this morning was just marked a dup of this one.  I
read the comments on this one, did a rpm -q gamin, and I got
gamin-0.0.17-1.FC3.  So shouldn't this be fixed on my system?  It's
not, you know.
Comment 16 sangu 2005-02-10 20:13:46 EST
Please See : http://bugzilla.gnome.org/show_bug.cgi?id=165955

gamin version is 0.0.23-1.

This problem still happens.
Comment 17 sangu 2005-02-12 23:23:42 EST
bug 127612 bug 130859 bug 139116 bug 143679 bug 147195

This bugs seem to see the same problem.
Comment 18 Juan C Nuno 2005-02-18 18:26:49 EST
[nuno@swing ~]$ rpm -q gamin
gamin-0.0.24-1.FC3

And it's still broken.  Just now I downloaded an xorg.conf using Firefox and I
had to do a Ctrl+R to see it on the desktop.
Comment 19 Daniel Veillard 2005-02-19 06:52:24 EST
That works for me. With 0.0.24 I can't reproduce the bug anymore.
Make sure your killed all gam_servers or restarted the session.

Daniel
Comment 20 Juan C Nuno 2005-02-19 12:33:47 EST
Well, I'm merely a Linux newbie, so I don't know how to "kill all my
gam_servers" or "restart my session."  So I just rebooted.  And the problem is
still there.  I edited a Java source file with gedit, compiled it from the
command line with javac, and neither the source file nor the class file showed
up on the desktop.  A Ctrl+R revealed them both.

[nuno@redux-ii ~]$ rpm -q gamin
gamin-0.0.24-1.FC3

This problem is still there for me.  And I have to say it's the most annoying
one by far.

Not that all your hard work isn't appreciated guys, because I do.  I write this
bug report not to hate, but only to love.

Note You need to log in before you can comment on or make changes to this bug.