Bug 133509 - badness in interruptible sleep_on_timeout
badness in interruptible sleep_on_timeout
Status: CLOSED DUPLICATE of bug 127018
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-24 11:54 EDT by Neal Becker
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2004-09-24 11:54:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
This occured on shutdown:

Sep 24 07:29:25 rpppc1 kernel: Badness in interruptible_sleep_on_timeout at kernel/sched.c:3004
Sep 24 07:29:25 rpppc1 kernel:  [<022f7ba4>] interruptible_sleep_on_timeout+0x5d/0x23a
Sep 24 07:29:25 rpppc1 kernel:  [<0211b5bd>] default_wake_function+0x0/0xc
Sep 24 07:29:25 rpppc1 kernel:  [<435509e6>] lockd_down+0xb4/0x258 [lockd]
Sep 24 07:29:25 rpppc1 kernel:  [<435fa40a>] nfs_kill_super+0x43/0x63 [nfs]
Sep 24 07:29:25 rpppc1 kernel:  [<02167d56>] deactivate_super+0xcb/0xe0
Sep 24 07:29:25 rpppc1 kernel:  [<021848cc>] sys_umount+0x65/0x6c
Sep 24 07:29:25 rpppc1 kernel:  [<0217f60b>] destroy_inode+0x36/0x45
Sep 24 07:29:25 rpppc1 kernel:  [<0217b0a3>] dput+0x33/0x4f3
Sep 24 07:29:25 rpppc1 kernel:  [<021624c6>] __fput+0xc9/0xee
Sep 24 07:29:25 rpppc1 kernel:  [<021848de>] sys_oldumount+0xb/0xe
SeSep 24 07:29:25 rpppc1 kernel: Badness in interruptible_sleep_on_timeout at kernel/sched.c:3004
Sep 24 07:29:25 rpppc1 kernel:  [<022f7ba4>] interruptible_sleep_on_timeout+0x5d/0x23a
Sep 24 07:29:25 rpppc1 kernel:  [<0211b5bd>] default_wake_function+0x0/0xc
Sep 24 07:29:25 rpppc1 kernel:  [<435509e6>] lockd_down+0xb4/0x258 [lockd]
Sep 24 07:29:25 rpppc1 kernel:  [<435fa40a>] nfs_kill_super+0x43/0x63 [nfs]
Sep 24 07:29:25 rpppc1 kernel:  [<02167d56>] deactivate_super+0xcb/0xe0
Sep 24 07:29:25 rpppc1 kernel:  [<021848cc>] sys_umount+0x65/0x6c
Sep 24 07:29:25 rpppc1 kernel:  [<0217f60b>] destroy_inode+0x36/0x45
Sep 24 07:29:25 rpppc1 kernel:  [<0217b0a3>] dput+0x33/0x4f3
Sep 24 07:29:25 rpppc1 kernel:  [<021624c6>] __fput+0xc9/0xee
Sep 24 07:29:25 rpppc1 kernel:  [<021848de>] sys_oldumount+0xb/0xe
Se

Version-Release number of selected component (if applicable):
2.6.8-1.541 #1

How reproducible:
Didn't try

Steps to Reproduce:
1.shutdown
2.
3.
    

Additional info:
Comment 1 Jon Burgess 2004-09-28 17:42:32 EDT
I see the same as well. It occurs whenever I umount an NFS drive.
It also seems to cause all further NFS mount attempts to fail (but i'm
not certain about this).
Comment 2 Elliot Lee 2004-10-13 16:18:13 EDT

*** This bug has been marked as a duplicate of 127018 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.