Bug 1335186 - hosted-engine vm and storage domain not displayed in the admin web ui
Summary: hosted-engine vm and storage domain not displayed in the admin web ui
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Arik
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks: 1335177
TreeView+ depends on / blocked
 
Reported: 2016-05-11 13:50 UTC by Sandro Bonazzola
Modified: 2017-05-11 09:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 07:39:00 UTC
oVirt Team: Virt
Embargoed:
rule-engine: ovirt-4.0.0+
rule-engine: blocker+
rule-engine: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
host sosreport (7.36 MB, application/x-xz)
2016-05-12 09:15 UTC, Sandro Bonazzola
no flags Details
engine sosreport (5.79 MB, application/x-xz)
2016-05-12 09:19 UTC, Sandro Bonazzola
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 57458 0 master MERGED core: fix NPE while detecting external vm 2016-05-15 12:33:24 UTC

Description Sandro Bonazzola 2016-05-11 13:50:49 UTC
Description of problem:
- Installed NGN
- Deployed HE using appliance
- Attached a data domain

HE VM and storage domain are not displayed in the admin web ui.

Comment 1 Sandro Bonazzola 2016-05-12 09:15:28 UTC
Created attachment 1156573 [details]
host sosreport

Comment 2 Sandro Bonazzola 2016-05-12 09:19:10 UTC
Created attachment 1156576 [details]
engine sosreport

Comment 3 Doron Fediuck 2016-05-15 08:40:57 UTC
Import failed due to a monitoring issue.
Arik, please review-

2016-05-12 08:54:45,390 ERROR [org.ovirt.engine.core.vdsbroker.monitoring.VmsMonitoring] (DefaultQuartzScheduler_Worker-49) [] Failed during vms monitoring on host hosted_engine_1 error is: java.lang.NullPointerException
2016-05-12 08:54:45,390 ERROR [org.ovirt.engine.core.vdsbroker.monitoring.VmsMonitoring] (DefaultQuartzScheduler_Worker-49) [] Exception:: java.lang.NullPointerException
	at org.ovirt.engine.core.vdsbroker.monitoring.VmAnalyzerFactory.getVmAnalyzer(VmAnalyzerFactory.java:79) [vdsbroker.jar:]
	at org.ovirt.engine.core.vdsbroker.monitoring.VmsMonitoring.lambda$analyzeVms$1(VmsMonitoring.java:161) [vdsbroker.jar:]
	at java.util.ArrayList.forEach(ArrayList.java:1249) [rt.jar:1.8.0_91]
	at org.ovirt.engine.core.vdsbroker.monitoring.VmsMonitoring.analyzeVms(VmsMonitoring.java:158) [vdsbroker.jar:]
	at org.ovirt.engine.core.vdsbroker.monitoring.VmsMonitoring.perform(VmsMonitoring.java:121) [vdsbroker.jar:]
	at org.ovirt.engine.core.vdsbroker.monitoring.PollVmStatsRefresher.poll(PollVmStatsRefresher.java:39) [vdsbroker.jar:]
	at sun.reflect.GeneratedMethodAccessor109.invoke(Unknown Source) [:1.8.0_91]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_91]
	at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_91]
	at org.ovirt.engine.core.utils.timer.JobWrapper.invokeMethod(JobWrapper.java:77) [scheduler.jar:]
	at org.ovirt.engine.core.utils.timer.JobWrapper.execute(JobWrapper.java:51) [scheduler.jar:]
	at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [quartz.jar:]
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557) [quartz.jar:]

Comment 4 Arik 2016-05-15 11:32:52 UTC
This is a regression caused by recent refactoring in VMs-monitoring.
Patch will be posted soon.

Comment 5 Red Hat Bugzilla Rules Engine 2016-05-16 09:12:35 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 6 Artyom 2016-06-20 08:18:19 UTC
Verified on rhevm-4.0.0.4-0.1.el7ev.noarch
1) Deploy hosted engine
2) Add NFS master storage domain to the engine

HE auto-import succeed.

Comment 7 Sandro Bonazzola 2016-07-05 07:39:00 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.